I think I broke my router? (RT3200)

At first, I tried to select the file openwrt-mediatek-mt7622-linksys_e8450-squashfs-sysupgrade.bin as the update file for my router, that did nothing, then I tried using openwrt-mediatek-mt7622-linksys_e8450-initramfs-kernel.bin, and now my router is broken I think. Would someone please help me? I was going to use this, but the script didn't work.

The reason I say bricked is that when I try to connect to the internet, nothing shows up. Like it's not even that there is a connection with no internet, there is no connection. On the router there is a flashing power light and the internet light isn't on at all. It worked before with the default software. I tried resetting it (holding the reset button for 20 seconds) and that did nothing.

OS: openSUSE Tumbleweed with KDE Plasma
Hardware: Belkin RT3200
Software Version: Snapshot (I think)

here is what happened when I tried the script, by the way.

Two things: Now the connection at least shows up, but the ping brings back nothing.


We spoke also on #openwrt channel, and you say: 'but I don't know much about networking'.
Why updating your router in the first place with not much networking knowledge?
OpenWrt is open-source, wider focused, but not always faster / better then router brand-firmware, and DO need basic [ even more ] knowledge of networking. It is sometimes used to specialize devices within networks.

What i guess went wrong is: you flashed the wrong firmware (there is not even a STABLE version for your router, yet)?
Maybe Belkin has some recovery software to re-establish a working router? https://www.belkin.com/us/support-article?articleNum=317303
There is only 1.0 version available for that router? Is it that new?

Try to fix this you want to make your own OpenWrt firmware on OS: openSUSE Tumbleweed with KDE Plasma (and get the script error, picture).
But even when that would work, how to get that 'new' firmware on a router with no access?

First things first:
You need 3 things, a PC, a cable and the router. When connected, does the PC gets an ip address from router? PC - cable - router
Yes, that's good! now you can try the routers web-interface and flash Belkin's latest (only?) firmware.
No, try for your PC and ping
Does this work?
Yes, try the routers web-interface and flash Belkin's latest firmware.
Now it is time to try serial connection, open the router and de-brick by using special TTL-serial device to connect to the router etc. etc. deeper into reverse engineering. Now you even have to know basic electronic and computer knowledge.

When interested, feel free to ask more, but always try to be as specific as possible.


Dear experts,

I have done the same, installed the latest snapshot initramfs firmware, but it does not boot up. :frowning:
BTW, the reset button restores the factory firmware.
What should I do to have Openwrt?

Thank you,

Initramfs doesn't get written to flash, it only runs in RAM, if/when you reboot the router, it's gone.

It not booting, would be another issue.