I think I bricked my R7900

So, I think the first thing I did with my LEDE installation was brick my device.

  1. The setup
    Flashing the device went fine, and I was able to get into Luci to setup things, but not able to connect to the internet. Then I set the service type to dhcp instead of static, figuring it would then get an IP assigned from the router upstream of it.
    Only, now it isn't on and I can't find any ips with an open port 80 or 22.

  2. The attempts:
    I tried a hardware reset, but never got a flashing power light.

I then setup wireshark and notice that it is sourcing a lot of stuff from on the eth2 connection.
Also, it never broadcast the 'push button to reset' message during startup

I can get into the upstream router and see that the LEDE device is getting an ip, but I think LEDE firewalls out connections from the WAN side.

While connected to LEDE device, I ran a port scan to find any IP with an open 80 or 22, but didn't find any.

I tried the TFTP fix, but couldn't find an IP address for the LEDE device while connected to the LAN, and the WAN is firewalled off.

  1. Any suggestions?

The mistake is naturally setting the routers lan prtocol to dhcp. It should have been static. And then wan is upstream dhcp...

Some ideas:

Openwrt LEDE failsafe mode. That should revert network to default failsafe is tricky to get into as it requires button push inside a two second window during boot. Best can be to push some button rapidly until the LED starts really rapid blinking.

Other fancy idea might be trying to setup a dhcp server in lan. As router seeks now dhcp address, just provide one. E.g. run a dhcp server in your PC. Then the router might get a valid address and you could login into that.

1 Like

I tried the failsafe boot idea, but somehow that didn't seem to work.
I'll look into setting up dhcp on my workstation.

Thank you for your guidance.

The solution!

From the upstream router, connect both to both the LAN and the WAN port with two cables. Use the LAN port IP to get to Luci.

Great that the "provide DHCP server for LAN" idea worked.