I noticed a bug when running luci-i18n-https-dns-proxy-ru with three dns

Hi all
Two DNS resolvers work fine, but I added a third one and when I rebooted the router, the https-dns-proxy service did not turn on, sometimes it turns on, sometimes it doesn’t.
Just in case, I added the command to autorun
( sleep 5 && /etc/init.d/https-dns-proxy start )

I also noticed that if you remove the third dns from dnsmasq
sed -i '/list server '''127.0.0.1#5055'''/d' /etc/config/dhcp
/etc/init.d/dnsmasq restart
then https-dns-proxy will work for a while and stop.

the task was to remove the third dns from dnsmasq at system startup, having previously added to the redirection, for example, for the third dns
/*.com/127.0.0.1#5055
, so that the third dns would only access the .com domain, but in this case the service is always https- dns-proxy will work for a while and stop.
In any case, with three dns when the system starts, the service may not start

I think the problem has been resolved.
I stopped the https-dns-proxy service and disabled it, then in the dnsmasq section I added the redirection manually and saved it.
/mask.icloud.com/
/mask-h2.icloud.com/
/use-application-dns.net/
127.0.0.1#5053
127.0.0.1#5054
127.0.0.1#5055
then turned on https-dns-proxy back and launched
and now even if you stop this service, everything is preserved in dnsmasq.
I may have had a conflict with adblock, since I set it to clear cache in its settings