I need to share wifi via my computer to router for extroot, but the router doesn't have internet

I have a GL-MT300N-V2 mango that wont connect to windows internet sharing. I have set up my pc to transfer Wi-Fi to my ethernet port. I'm doing this because I do not have direct ethernet access to my access point router, and I need to setup extroot on the mango router, and I could not install pkgs with opkg due to no internet. I connected the WAN port to the LAN of my pc, but when I did a ping to google to ensure I had internet, it reported with "Bad address: google.com". I have tried to set my ethernets IP to and the default gateway on the router to, but I still didn't have internet. I'm using ICS (Internet connection sharing) on my pc, but to no avail, it failed to connect. I've tried 'route' to set the gateway. DHCP is not working, but when I had stock firmware, the static ip setting worked perfectly. Also to point out, ssh does not work on wan at all, lan works when internet sharing is off.

You could just connect the mango to wifi directly.

As long as you associate that connection with the wan fireawll zone, you should have internet access on the router so that you can install the desired packages.

You may need to change the LAN address of your mango if you plan to use it to provide internet access via the ethernet port. (the subnet of the lan must be different than the upstream network).

1 Like

Does setting the WAN firewall settings in '/etc/config/firewall' to accept output and input for the WAN interface count? Also how do I associate the connection with the wan firewall. I have some settings on my computer that allow my to access my wifi, so if I did connect the router to wifi, many certificate errors would pop-up.

No. The change (making input = accept) simply makes the router itself open to the wan... this should be drop or reject in the vast majority of cases. In your situation, it won't help.

Did you read the link I provided? It explains how to do this.

I'm not sure what you're talking about here. Is your wifi non-standard, or using something like WPA2 Enterprise authentication?

The whole point of my suggestion is that your OpenWrt Mango would simply connect to the wifi directly as a client, and the device itself would operate in the standard/default routing mode with NAT masquerading enabled (to which you can easily connect your computer). This would make it possible for the Mango to get online so that it would have internet access for the extroot process. This should work unless there is something unusual about your existing wifi network or its credentials.