I need Little help for VLAN IPTV sessions

Hi every one,
I need some support on my IPTV link.
My IPTV connection and PPPOE WAN connection works very good on tp-link Archer c6v3.2 openwrt router version 23.05.04.
Every morning when I open the TV I face with a blank TV screen and when I press the OK button on the remote control, the STB displays "There are no servers to connect" message with the code "109000" and when i reboot the router or the STB everything works smooth again.

My isp needs a certain VLAN (103) for the IPTV to work, no igmp proxy or something like that is needed.

I made the fallowing config to make IPTV to work : (STB directly connected to LAN4 by Ethernet cable)

a. took LAN4 apart from the main lan bridge (br-lan, no Bridge VLANS)
b. made a bridge called br-iptv with LAN4 and WAN.103 (No Bridge VLANS)
c. made an interface called iptv using br-iptv (Proto DHCP client , no DHCP server , no Firewall settings).

With the above config all works fine but i get "There are no servers to connect" by STB every morning when I wake up and need to reboot router or STB which is annoying :slight_smile: .

May somebody help me on this issue?
Thank you.

Below are a few screenshots of my config if it helps and I may provide more info if needed.

You almost certainly need to use bridge-vlans for this. Let's see your config:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network

Thanks for your response,

 -----------------------------------------------------
 OpenWrt 23.05.4, r24012-d8dd03c46f
 -----------------------------------------------------
root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.162",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "TP-Link Archer C6 v3",
        "board_name": "tplink,archer-c6-v3",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.4",
                "revision": "r24012-d8dd03c46f",
                "target": "ramips/mt7621",
                "description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb9:4f14:31a2::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'pppoe'
        option username 'xxx'
        option password 'xxx'
        option ipv6 'auto'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '103'
        option name 'wan.103'
        option mtu '1492'
        option macaddr 'C0:FD:84:EF:8B:84'
        option ipv6 '0'

config device
        option type 'bridge'
        option name 'br-iptv'
        option ipv6 '0'
        option mtu '1500'
        option txqueuelen '1000'
        list ports 'lan4'
        list ports 'wan.103'

config interface 'iptv'
        option proto 'dhcp'
        option device 'br-iptv'

root@OpenWrt:~#

This won't work, so it should be deleted.

Lkewise, remove this:

Put port lan4 and the wan into br-lan so it looks like this:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan'

Create bridge VLANs for your lan, wan, and iptv:

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1:u*'
        list ports 'lan2:u*'
        list ports 'lan3:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '2'
        list ports 'wan:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '103'
        list ports 'lan4:t'
        list ports 'wan:t'

Edit the lan interface to use br-lan.1:

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

The wan will use br-lan.2:

config interface 'wan'
        option device 'br-lan.2'
        option proto 'pppoe'
        option username 'xxx'
        option password 'xxx'
        option ipv6 'auto'

config interface 'wan6'
        option device 'br-lan.2'
        option proto 'dhcpv6'

and the iptv network will use br-lan.103. It will also be unmanaged:

config interface 'iptv'
        option proto 'none'
        option device 'br-lan.103'

Once those changes are complete, reboot and test.

Thanks for the detailed answer , I will test your configuration and will be back with the result.
Thank you.

With your configuration iptv did not work but when I change 'lan4:t' to
'lan4:u' in VLAN103

config bridge-vlan
        option device 'br-lan'
        option vlan '103'
        list ports 'lan4:u*'
        list ports 'wan:t'

iptv now works and internet is ok.

I will test this working config 1-2 days I will be back with the result.

Thank you.

My last config is as fallows:

root@OpenWrt:~#  cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb9:4f14:31a2::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'br-lan.2'
        option proto 'pppoe'
        option username 'xxx'
        option password 'xxx'
        option ipv6 'auto'

config interface 'wan6'
        option device 'br-lan.2'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

config interface 'iptv'
        option proto 'none'
        option device 'br-lan.103'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1:u*'
        list ports 'lan2:u*'
        list ports 'lan3:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '2'
        list ports 'wan:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '103'
        list ports 'lan4:u*'
        list ports 'wan:t'

I'm slightly surprised that the IPTV box requires that the VLAN is untagged as I had generally figured it would expect the network to be tagged. But I guess it would make sense if the ISP's box would normally handle that.

Glad you figured that one out, though and that everything appears to be working.

Assuming no issues arise, and when you're ready:

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

Hi again

as I stated in the begining my problem is not to make iptv working. It works with my initially given confıguration but

my issue is

With the above config all works fine but i get "There are no servers to connect" by STB every morning when I wake up and need to reboot router or STB which is annoying

means for some reason rooter or stb looses iptv link after 5-6 hours.
I will test your config for this issue and mark your config as solution afterwards.
Thank you

Well, the previous configuration was not correct based on the way that DSA works on OpenWrt -- you can only have one bridge on the switch, and the bridge-VLANs are what will allow you to segment as you need.

Hopefully this will make it more stable. If not, the other question would be if this is an upstream issue. But let's see what happens over the next few hours/days.

Thank you wery much for you effort.

Hi again,
Unfortunately sitation is still the same. STB goes sleep mode every 4 hours and altough the link lamp shows green , it can not find the servers to be connected when it is made online with remote control. Rooter reboot takes everythig ino working state.

At this point, the router isn't really doing anything other than passing the VLANs. I suspect that the reboot of the router is helping because it causes the port to bounce. Therefore, instead of rebooting the router, next time just pull the Ethernet cable out of the STB for a few seconds and then plug it back in. If that resolves the issue, it points to an issue with either the STB or the upstream service (not the router).

Yes when I plug ethernet cable out and in after 10 seconds STB soft restarts and TV works as expected. But , the issue never happened with ISP's router since 5 years. So may we think my ISP has a non standart tricky implementation on their router for IPTV and return to original router?

This is a clear indicator that it is not OpenWrt specifically, as there is no magic for what is happening on that device -- it is literally passing the traffic through the switch, that's all.

I would be a good idea to replace your OpenWrt router with the ISP one in order to see if the problem replicates (in which case, you know it is 100% certain to be the ISP upstream or the STB itself at fault). If the problem doesn't reproduce, it would suggest that the ISP is doing something special on their system for proper functionality. If you can figure out what that is, you might be able to implement it in the OpenWrt config (although I wouldn't count on it until you have more info).

I can say that OpenWrt is not at fault here, insofar as it is operating as it should based on the configuration we have created; this just may be something that the ISP has layered on top of the standard connectivity (maybe a telemetry and then a token from the ISP > ISP router > STB??)

1 Like

Thank you very much.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.