I need help setting up multiple VPNs on my network

Hello Goodnight,
I had to reset my router to Openwrt factory settings.
Now I want to rejoin my mobile with my router using Wireguard. I think I do everything I have to do, but I still can't get Handshake.
I would appreciate if someone could help me find the bug, my knowledge does not give me, and I followed this guide, http: //chrisbuchan.co.uk/computing/wireguard-setup-openwrt/, but for some small detail, I can't.
I have my home network set up as follows.
FritzBox Kable 6591 with native operating system and then FritzBox 4040 with Openwrt.

1 Like

There is an official and tested guide for wg server. Make sure you apply it on a clean installation.

2 Likes

Did you, by any chance, create new keys for wireguard "server", running on the router after reset to factory settings, but didn't update them on your phone?

1 Like

I followed the steps in this guide, https://openwrt.org/docs/guide-user/services/vpn/wireguard/server, I do it by ssh, but I still can't get it to work. I think I do not put the DNS-Server of the wireguard app correctly, but I tried with everything I know

I don't think it's because of that. and installed wireguard from scratch with new keys. I did everything as they put in the guides and how I knew how to do again that I had it working

I personally recommend to perform the initial server setup using the automated script:
https://openwrt.org/docs/guide-user/services/vpn/wireguard/extras#automated

It generates client profiles which can be easily imported on mobile and desktop clients.
It has been tested on the latest OpenWrt release and appears to work pretty well.

3 Likes

It seems that at the moment the wireguard connection works with my mobile, but the following problem has arisen. I hope I can explain myself well.
I also have OpenVpn installed in which I have an .ovpn file, this to interface tun0. Routing there ip individually Vpn Policy Routing. It turns out that since I installed Wireguard, now when I route there some IP, it does not have internet and before if it worked for me, but only if I had to put a Gloogle DNS on the device I was routing.
I don't know if I was able to explain myself well, I'm sorry in advance, but I don't speak English and my computer skills are terribly poor

1 Like

This information, https://openwrt.org/docs/guide-user/services/vpn/wireguard/extras#automated, has been of great help to me. Not just the Automated Script thing. But the Automated Script thing is fine.
Good advice, Vgaetera.

1 Like

It sounds like you should disable gateway redirection in the OpenVPN client config:

pull-filter ignore redirect-gateway
2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.