I need help getting my hard drive to shutdown by itself

Hello partners! I am running the known packages of, transmission, samba4, minidlna on my router everything works fine. But the problem is that my connected hard drive never turns off, the only way is to stop all the mentioned services. By default my hard disk seagate expansion portable has configured to turn off after 15 minutes and this rule if it is fulfilled but not with the active services with openwrt. install "hd_idle" but it doesn't seem to work with the other active services.

I stopped minidlna and samba4 together and only left transmission active with two torrent stopped and I see how the led of my hard disk blinks and the disk turns on unnecessarily since not touching anything for 30 minutes.

Check this page https://openwrt.org/docs/guide-user/storage/usb-drives under Optional: Idle spindown timeout on disks for NAS usage


apparently he had a problem with the program or package "fstab" which did not finish its process. Adding the last line to my / etc / config / fstab file solved the problem.

config global
	option anon_swap '0'
	option auto_swap '1'
	option auto_mount '1'
	option delay_root '5'
	option check_fs '0'
	option anon_mount '1'

config mount
	option target '/mnt/sda1'
	option uuid '5db99dfb-feaf-4205-b76d-c95dc3d30cc0'
	option enabled '1'
	option options 'rw,relatime,data=writeback,errors=remount-ro,nodev,init_itable=0'

Also it had badly configured "hd-idle" it was in sda when it had to be sda1.

I hope someone is useful.


Good to hear. Please mark your reply as Solved so it’s easier for others to find.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.