I need help EngGnius 2910p

I install the https://openwrt.org/toh/engenius/ews2910p#supported_versions firmware and now no POE is working, unable to access from WebGUI. only able to access from cli with but I don't know how to go back with the factory image. I checked Dual firmware partition but only Linksys. I tried to follow same instructions but did not work I need help to go back to factory image or If POE works and able to access from WebGUI I can stay Opnwrt. Thank you!

You installed a Snapshot version. Snapshot images do not contain LuCI (the web interface). However, you can easily install it by either running opkg update && opkg install luci or by using the firmware selector at https://firmware-selector.openwrt.org/

Regarding PoE, you might need to install realtek-poe package if it's not already installed. If it is already installed, you need to configure it in /etc/config/poe. There is no GUI support for PoE. You can check if it works by running ubus call poe status.


Thank you @andyboeh If I make it default gateway and device IP I can able to login ssh using putty. It cannot get internet from the DHCP server, Device is not showing in the list of DHCP servers to update the LuCI and other packages.

You need to configure the LAN interface as a DHCP Client. However, firmware-selector with LuCI included, scp and sysupgrade is probably easier and faster!

1 Like

Can you please help me how to perform firmware-selector with LuCI included, scp and sysupgrade is probably easier and faster!

I'm not familiar with OpnWrt switch and need community help to resolve it.

If I connect to the switch to DHCP server, I do not get IP from DHCP server to the SW, but if I connect any device on it like the pic it will get IP as well as Internet and I can see the device in the DHCP server list. I cannot access switch without manually changing static IP on news 192. 168.1.1 and if do that I cannot get internet to update the packages from CLI.

In the firmware selector your switch is called EnGenius EWP2910P (not sure why).
Then you click "Customize installed packages and/or first boot script" and there is the list of the packages that are being installed. Here you add the packages you want to the end of the list:

luci realtek-poe

... and then you press "REQUEST BUILD"

Regarding that you don't get a IP from the DHCP server: The standard configuration after a fresh installation is that OpenWrt acts as an DHCP server itself on the LAN ports, and not as a DHCP client.

To configure it as a DHCP client please read OpenWrt as client device.

1 Like

On routers, yes. On switches, it only has a static IP of and acts neither as DHCP client nor as DHCP server (in order not to mess up your network).

1 Like

Oh, I see, thanks for explaining it, wasn't aware of that.
So if he'd like LAN to act as an DHCP client would it then be enough to add

uci set network.lan.proto="dhcp"

to " Script to run on first boot (uci-defaults)" in the firmware selector?

Good question, I don't know. I usually create an alias interface for LAN with proto DHCP so that I can still access the switch with its static IP If needed.

This is for sure the better option, you're right. That's the behaviour you would expect from a switch. And it can be done with uci-default too.

I used WinSCP and transfer the image to the tmp folder and run the cmd from putty sysupgrade -v /tmp/*openwrt-realtek-rtl838x-engenius_ews2910p-squashfs-sysupgrade.bin it went through but noting works.
Is there the way to reverse back to manufacture firmware? I have the manufacture image but I don't how to flash. Thank you all!

If it went fine, then you should have LuCI now!?

No, it will not changed anything after reboot I tried to go on Web GUI it won't load. That IP address is my router reserved IP. I changed PC NIC with, and Gateway Network work fine. I can ping any local IP address. I can so ssh and do SCP but unable to update packages or access Web GUI. Thank you!

I don't get why the switch should have this IP now? What options did you use for the firmware selector?

What output did you get when running sysupgrade with the new firmware file?

I switched that IP because it is in my DHCP-reserved IP range. To access SW with CLI as well as not lose the internet connection. Now I can access the internet as well as SW without changing the setting PC NIC IP address.

Is this the image after Sysupgrade cmd run. Is this correct or something went wrong?

Thank you! both @andyboeh @patient0 for your great support. I finally able to get the things working at least Luci. Here is the solution.
after upload Firmware OpenWrt snapshot Install need to upgrade to Firmware OpenWrt snapshot Upgrade but need to do something to works.

like cmd

uci set network.lan.proto="dhcp"
uci commit network
/etc/init.d/network restart

It will get ip from dhcp server and and able to update opkg
Still need to figure out how enable poe.
Thank you all and OpnWrt community!

In the firmware selector your switch is called EnGenius EWP2910P (not sure why).

It's a typo in the rtl838x.mk file "DEVICE_MODEL := EWP2910P". I'll submit a pull request to fix the issue!

Pull request submitted: realtek: Fix typo in rtl838x.mk file

1 Like

Recently I updated to EnGenius EWS2910P to 23.05.0-rc1 (r23069-e2701e0f33) but after updating it stays in the System running in recovery (initramfs) mode. Even I updated the sysupgrade image. I tried to rest to firstboot reboot now and re-uploaded the new images and nothing happens. I tried to do 30/30/30 still the same. I tried to update the manufacturer image and it will sit on the same OpenWrt image in the System running in recovery (initramfs) mode. I need help to fix this issue. Please help. Thank you

Changing the boot partition resolved the issues but POE stop working. If go to stock firmware it won't hold the config after reboot, It will reset to the factory setting. If I flash with OpenWrt image (openwrt-23.05.0-rc2-realtek-rtl838x-engenius_ews2910p-initramfs-kernel.bin) it will work but after upgrading with (openwrt-23.05.0-rc2-realtek-rtl838x-engenius_ews2910p-squashfs-sysupgrade.bin) POE stops working.