i.MX 93 stuck at "starting kernel ..."

Hello !

I’m working on getting an i.MX 93 Evaluation Kit running with OpenWrt version 22.03. My problem is the boot process hangs after printing out “Starting kernel …”. Based on the output does anyone have any suspicions to the problem or have any suggestions on where to go from here to get some more information from the kernel? I can provide further information if needed.

Here is the output during the boot process:

U-Boot SPL 2022.04-lf_v2022.04+g181859317b (Nov 15 2022 - 06:28:05 +0000)
SOC: 0xa0009300
LC: 0x40010
Error: ahab_release_m33_trout: ret -5, response 0xf429
M33 prepare ok
U-Boot SPL 2022.04-lf_v2022.04+g181859317b (Nov 15 2022 - 06:28:05 +0000)
SOC: 0xa0009300
LC: 0x40010
M33 prepare ok
Normal Boot
Trying to boot from BOOTROM
Boot Stage: Primary boot
image offset 0x8000, pagesize 0x200, ivt offset 0x0
Load image from 0x48000 by ROM_API
NOTICE: BL31: v2.6(release):android-13.0.0_1.0.0-rc2-14-g3c1583ba0
NOTICE: BL31: Built : 11:00:38, Nov 21 2022
U-Boot 2022.04-lf_v2022.04+g181859317b (Nov 15 2022 - 06:28:05 +0000)
CPU: i.MX93(52) rev1.0 1700 MHz (running at 1692 MHz)
CPU: Consumer temperature grade (0C to 95C) at 35C
Reset cause: CSU (0x200)
Model: NXP i.MX93 11X11 EVK board
DRAM: 2 GiB
TCPC: Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C2 0x52]
TCPC: Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C2 0x51]
TCPC: Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C2 0x50]
Core: 211 devices, 29 uclasses, devicetree: separate
MMC: FSL_SDHC: 0, FSL_SDHC: 1
Loading Environment from MMC... OK
[*]-Video Link 0adv7535_mipi2hdmi hdmi@3d: Can't find cec device id=0x3
fail to probe panel device hdmi@3d
fail to get display timings
probe video device failed, ret -19
[0] lcd-controller@4ae30000, video
[1] dsi@4ae10000, video_bridge
[2] hdmi@3d, panel
adv7535_mipi2hdmi hdmi@3d: Can't find cec device id=0x3c
fail to probe panel device hdmi@3d
fail to get display timings
probe video device failed, ret -19
In: serial
Out: serial
Err: serial
BuildInfo:
- ELE firmware version 0.0.8-80d3db4b
switch to partitions #0, OK
mmc1 is current device
flash target is MMC:1
Net: eth0: ethernet@42890000, eth1: ethernet@428a0000 [PRIME
Fastboot: Normal
Normal Boot
Hit any key to stop autoboot: 0
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:1...
42804 bytes read in 4 ms (10.2 MiB/s)
Scanning disk mmc@42850000.blk...
Scanning disk mmc@42860000.blk...
Found 6 disks
No EFI system partition
adv7535_mipi2hdmi hdmi@3d: Can't find cec device id=0x3c
fail to probe panel device hdmi@3d
fail to get display timings
BootOrder not defined
EFI boot manager: Cannot load any image
switch to partitions #0, OK
mmc1 is current device
Scanning mmc 1:1...
BootOrder not defined
EFI boot manager: Cannot load any image
starting USB...
Bus usb@4c100000: tcpc_setup_ufp_mode: Polling ALERT register, TCPC_ALERT_CC_STATUS bit failed, ret = -62
Port not available.
Bus usb@4c200000: tcpc_setup_ufp_mode: Polling ALERT register, TCPC_ALERT_CC_STATUS bit failed, ret = -62
Port not available.
USB is stopped. Please issue 'usb start' first.
Running BSP bootcmd ...
switch to partitions #0, OK
mmc1 is current device
Can't set block device
16254984 bytes read in 172 ms (90.1 MiB/s)
Booting from mmc ...
43801 bytes read in 2 ms (20.9 MiB/s)
## Flattened Device Tree blob at 83000000
Booting using the fdt blob at 0x83000000
Using Device Tree in place at 0000000083000000, end 000000008300db18
adv7535_mipi2hdmi hdmi@3d: Can't find cec device id=0x3c
fail to probe panel device hdmi@3d
fail to get display timings
probe video device failed, ret -19
Starting kernel ...