I’m sure it’s been covered- no internet using OpenWrt newb

Good morning and apologies for disturbing you.

I have bought a linksys wrt32x , just because elf Superhub WiFi is garbage , so I thought I’d try something with more go.

Anyways it’s come installed with OpenWrt (current version) .

I’m not sure it’s for me as I can’t seem to get it to do anything other than broadcast my ssid , but can’t actually use them.

I have been trying for 24 hours straight at this point and almost feel suicidal .

Router is working , is responsive . Can open Wrt fine and connect using putty (although ive no idea what to do with it)

All I wanted was a simple WiFi upgrade, instead I’ve got a headache and a reseller who has disappeared.

I’m not massively technical, but can follow instructions , but what I’ve read on here assumes you know what most terms and softwares etc are . Can anyone help either simpleton terms in setting up , or ideally I think reverting to stock firmware , where at least linksys will help .

Thanks for taking the time to look, I don’t think I can contribute much back to this forum .

Are you? Am I?

Exceptionally obscure title.
And the contents are obscure too.

Even after reading your message I am not sure, what you actual problem is...
revert the modem? wrt32x has no modem...

If you just want to revert WRT32x back to Linksys default OEM firmware, just download the Linksys firmware for it, and use either LuCI or console sysupgrade to "force" flashing the OEM image to the router. Both the master snapshots and the "current" (=19.07.2) release firmwares support force also from LuCI.

You should stick with OpenWrt IMO. You can reset OpenWrt by going to the user interface at > Backup / Flash Firmware > Perform reset.

I have no idea what LucCI is , or sysupgrade ( although I think this is no longer an option due to having OpenWrt on both boots) ?

that could be dangerous if he have no idea what luci is. doing so if he have a snapshot on the router, he will be out of any web interface , and than the trouble start.

1 Like

Ok Im working my through this again ,

Ive set a new ssid to each radio signal, given them a wpa2 password, changed them all to uk and can see them all ok.

Ive changed superhub to modem mode , connected port 1 to internet port of router .Ive ensured wan port is set as dhcp . My pc is connected to port 1 of router – no internet . I don’t quite see where ive gone wrong.

I just dont understand why i cant get the data signal from my superhub 3 to my router , I put in modem mode , connect port 1 to internet port on router.

I open OpenWrt , and the 'WAN @ section is in red as in not active . Ive tried to play with several settings but just can get it to work .If it worked fine i'd leave OpenWrt on the router , as im just about understanding it now.

Once I can get it to work wired ,naming and setting up the wireless appears to be easy enough

By default the OpenWrt WAN interface is using DHCP protocol. This should work in most cases immediately, unless your provider is locking the MAC address of the modem and doesn't accept a different one.
Or the protocol should not be DHCP, but PPPoE.
You should copy the properties of the wan connection from your ISP's modem before you convert it into bridge mode. For example the PPPoE uses a username and password (and maybe some more things).

1 Like

If he's using a superhub 3 then I'm guessing he's on Virgin Media in the UK. There's no PPPOE details, just needs DHCP.

@Andio assuming the superhub 3 is already in bridge mode, disconnect everything from the superhub and restart it. Once it's back up immediately connect the openwrt router to it, openwrt should then hopefully get assigned the WAN IP.

1 Like

absolutely correct Krazeh , according to everything I read , should connect up select dhcp and should be golden. Im confused. However the internet light on the linksys doesnt respond differently whether i have a cable or not plugged into it from any source ??

Incedently there is no bridge mode in name on the hub

Hi I have this happen to me some times. The vm hub does have modem moad and it will give your router a IP using dhcp. what you need to do is power off the hub and the router at the same time then power on the hub wate for 30 seconds then power on the router it should work.

Thanks Tapper , ive tried , I can get internet via the wired connection on the back of the router now , just no wifi . Must be something im setting up

Hallelujah ...Im in . The staggered reboot , followed by another router reset and we are alive . That has been a long hard slog , but i have genuine euphoria now !!

Now if anyone has got any patience left with me , how can i prioritise my lan connection to my gaming PC ? I used to get 350 + mb now i only get 120 .... the kids wi fi connections are quicker lol

From your PC run this test.
You want to get a A for BufferBloat.

Under wifie settings check that you have
80 MHz Encryption
WPA2-PSK (strong security)
Force CCMP (AES)

Plus when you get it working you should check you have the latest build of openwrt. Let me know what build you have and I will send you the link for the latest.

Tapper your a legend , sorry I just came off and had a break from screen time . I will run , and check tomorrow. Appreciate your help.