I forgot my log in password! Help!

First and Foremost greetings to everyone that clicked on my post. Thank you in advance. So the past 48 hours I've been pulling my hair trying to figure out what my password is for my LEDE router. I changed it last week just to log in and see my network status and etc. Two days ago I tried logging in after I noticed I was receiving high latency on my Xbox one X detailed network test. Latency was so high that I also noticed my NAT was also on Strict. So I said maybe,Upnp or some ports need to be opened on the router as I don't remember doing any of this when I logged in various times. So I tried logging in, using the credentials I normally used on most of all my network devices. Nope, couldn't log in. Tried every single password I can think of that I've used previously. Nothing. So I decided , maybe I'll just reset the router to default settings. Now this is where I'm stumped. I've tried by resetting the router through the reset button on the back of the device. Tried getting the router into the "failsafe" mode and the directions I have read online on getting to boot to the failsafe mode was a bit confusing for me. Some say use SSH, some say just press the reset button on the back. I've tried almost all the methods and I'm either doing something wrong because I can't reset the router to default or boot it to failsafe. Can someone please assist me on this. My router is a Netgear WNDR4000. I'm so bugged out.

SSH requires a password...obviously for your protection.

If you are unable to get into failsafe mode, I would revert to the stock Netgear firmware and flash again.

After setting the password, save your configuration...then save it before making any changes to your setup.

Dumb question but how do I revert back to OEM firmware? If you can link me to a tutorial or something I would really appreciate it.

you have to play around a bit with the reset-button. Wait 0.5sec and press after power on. If that doesn't work, wait 0.7sec until you press it for at least 5 seconds. On some models it's really tricky to get the right timing to bring the router into failsafe. On my it's 1-2 seconds after power on until I press the reset-button.

Otherwise here are tipps for flashing your netgear to oem firmware:

Thank you so much. I'll try the failsafe again with your instructions. I'll revert back to OEM as a last resort option. Thank you again guys I really appreciate the replies. Bless you.

No luck. In the TFTP method I get an error or so response from server. Gosh this so frustrating.

you forgot your root password? cant do a factory reset?

Make sure the TFTP program has permissions through the firewall.

As an aside (and obviously for the future), I have decided that it's worth taping a sticky note to the bottom of each of my routers with this info:

  • Router firmware version
  • Date flashed
  • Router IP address
  • User (usually root)
  • Password

There's no particular loss of security (if the bad guys can look at the bottom of the router in your home, all is lost). It also helps if you get a new router. You'll have forgotten the old router's credentials when you go to re-use it, but the sticky note will remind you..

Good luck recovering access to the router.

This is one reason why it's recommended to always have a way to gain serial access via a USB-TTL Cable, USB-to-UART, SBC (Arduino, RasberryPi, etc.), or a breakout board (such as a MAX232), before flashing 3rd party firmware.

1 Like

If you were using a chrome or firefox browser to access the router's web configuration and had previously click on remembered password, there is a good chance to get the password.

For Chrome:

  1. Go to Chrome Menu / Settings / Advanced / Passwords and forms / Manage passwords .
  2. This menu contains all passwords saved by your browser in the format Website – Username – Password .
  3. By default, the password is hidden. Click on the eye-shaped button or show to see the password .

For Firefox:
Click the menu button and choose Preferences.
Click the Security panel.
Click Saved Logins… under Forms & Passwords. The Password Manager will open. Confirm to see passwords.

You may see list of the same IP address, if you have previously change any passwords on the same IP address or website. Maybe some can reveal some hints as to what you had changed.

Good luck!

I know this topic is old, but I had the same problem. I tried everything to get in to fail safe mode - did not work.

My solution was to utilize the internal serial port of the WNDR4000. You will need a TTL <-> RS232 level shifter, because the WNDR4000 runs on 3.3 Volts.
Baud Rate is 115200.
Connect with Putty -> brilliant.

Might this thread win the award for most depressing OpenWrt thread of all time?

We never even got to know whether he solved his problem.

Any worse threads out there to at least make this one look less depressing?

@FelzX that is pretty neat by the way. How on Earth did you figure that out?

The Idea I got from here: https://openwrt.org/toh/netgear/wndr4300#serial. The location of the jumper pads in the WNDR4000 is just a little different.

1 Like

most if not all devices have some form of onboard TTL serial console pins on the board, and OpenWrt does not have a password on serial console by default. So the "open the device and connect a USB-TTL adapter" (or case mod the router to have the adapter attached permanently) will work for most devices.