I flashed openwrt on Asus rt-ax53u but getting bad speed on ethernet cable

Sorry im a network noob. So ive configured wireless on both the bands and im getting full Internet speed on wifi.

But the weird thing is - im not even getting 1/10th of the Internet speed when i connect using the ethernet cable into my router's LAN port. How is this possible and what can I do to fix this ?

Any help is highly appreciated! Please let me know if you want me to provide some output of some command and I'll share them with you!

I just did a speed test and its so weird

Down - 12.45 Mbps
Up - 129.18 Mbps

cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd3d:5277:18d4::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        option ipv6 '0'
        option mtu '2000'
        option macaddr 'a.b.c.d.e.f'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '1.1.1.1'

config interface 'wan'
        option device 'wan'
        option proto 'static'
        option ipaddr '10.20.94.10'
        option netmask '255.255.255.128'
        option gateway '10.20.94.1'
        list dns '1.1.1.1'
        option type 'bridge'

config interface 'wan6'
        option device 'wan'
        option proto 'static'
        option ipaddr '10.20.94.10'
        option gateway '10.20.94.1'
        option netmask '255.255.255.128'
        list dns '1.1.1.1'
        option type 'bridge'

config device
        option name 'wan'
        option mtu '2000'
        option macaddr 'a.b.c.d.e.f'
        option ipv6 '0'

config device
        option name 'wlan0'
        option mtu '2000'
        option macaddr 'a.b.c.d.e.f'
        option ipv6 '0'

config device
        option name 'wlan1'
        option mtu '2000'
        option macaddr 'a.b.c.d.e.f'
        option ipv6 '0'

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HE20'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option key 'ok'
        option network 'lan'
        option ssid 'OpenWrt2.4GHz'
        option encryption 'psk2'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'ap'
        option encryption 'sae'
        option key 'ok'
        option network 'lan'
        option ssid 'OpenWrt5Ghz'

cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'
        option flow_offloading_hw '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

Thank you so much!

From the speedtest, I think someone or something is throttling my download speed on ethernet cable. I have tried doing speed tests in both windows and linux and I get the same result. So I think its not related to the OS itself. Maybe there is some setting in OpenWrt itself that I need to correct or something. I dont think my ISP is throttling it. Can you please help me ?

You've got another router upstream of your OpenWrt router... first check that you get the expected speeds when you bypass the Asus device.

Next, how did you arrive at the configuration you've shown -- especially the MTU. That is likely the cause of your issue.

There are lots of strange things happening in your network configuration:

The option type 'bridge' lines should not be in any network interface definitions:

Why is wan6 defined with IPv4? This is wrong. If you're not using IPv6, remove wan6 entirely.

MTUs are probably your problem (and in the lan interface). Just delete them unless there is a reason they need to be specified.

wlan devices should not be specified in the main network file, ever. Delete these:

1 Like