I don't know what to do. Help, please!

Hello. OpenWRT for me is something new, so I just downloaded it and installed it on my Asus RT-N12VP (D1). Then I tried to make the internet connection and I did something wrong in "interfaces'. Now I just can't connect to my router via browser or telnet. I tried to restore the firmware through Asus Firmware restoration, but it doesn't work.

Failsafe mode

1 Like

Which OpenWrt image exactly have you flashed?

1 Like

I assume you tried holding the reset button on the router for 30 seconds or following the firmware reset procedure for that router that you looked up online as the first step?

If that doesn't work then search for the word "debricking" followed by the name of your device and follow the procedure there. Normally this requires that some version of TFTP be utilized, either as the standard command or from a utility that the router manufacturer provides.

You cannot generally install firmware that requires it being supplied via TFTP with the windows firewall enabled. A lot of people say go to Linux to install but if you don't know Linux, you are looking at about a 2-5 year delay thrown in. If you are a Windows user, simply disable Windows firewall and you should be able to fix firmware via the documented rules found in the OpenWRT forums or help pages.

Also please try to include a little bit of the subject matter in the heading rather than just help. A basic configuration guide, is

  • connect a LAN cable from any one of the (normally 4) LAN ports and plug it into your computer and power on the router
  • do a Windows command (WIN+R and run "cmd"): Enter " ipconfig /all " (without quotes) and see what the router's gateway address is (normally and put that in the URL of your browser
  • enter the password you plan to use and after the login, navigate to System, Administration and type that same password in both fields, page to bottom and "save"
  • now if you want to access the router via wifi, then navigate to Network, Wireless and look under the heading and you'll have one or two radios and they will both be disabled. One likely is on a low band (b,g,n) and the other on the high band (a,n). So if you want to use one or both, whichever you want (has the Enable button present) click the Edit next to each radio that you want to use and configure it
  • configure radio by clicking on Edit, then page down to Interface Configuration and enter what you want your wifi beacon name to be and enter it in the ESSID field (something like HauntedHouse or FBI_investigator or whatever), then click the tab above that which says "Wireless Security". Now select WPA2-PSK and enter your password to access your network in the "key" field (click the "*" to see the password as you type it if you wish)
  • now scroll to the bottom and save that and you will be returned to the "Wireless Overview" screen where you will either configure the second radio or if you have only one, then click the "Enable" next to the radio you just Edited or configured. Now once it is enabled, then scroll to the bottom of the screen and click "Save and Apply".
  • now if you plug a LAN cable into the WAN port of the router (normally a different color than the 4 that are alike) and connect it into your cable or DSL modem, you should be good to go
  • If your ISP requires that you configure PPPoE on your router with a login ID and password given to you by your ISP, that is done by again going to Network, Interfaces and item in the list labeled "WAN" to the right clicking on the "Edit" key. Then change the protocol from DHCP client to PPPoE and enter the ID and password your ISP gave you.
  • save the changes and you should now be good to go
  • now don't mess with it again unless you get a non-production router that you want to play with (you'll generally take months or years to learn enough about this system to start experimenting; otherwise just enjoy it being a stable version of a router you will configure with more features as you read and learn)

** fixed typo

1 Like

I think you have a typo

Command should be ipconfig