I copy "config/wireless" from old Router: How-To fix "Wireless is not associated" and "Device is not active"

Hi

my new device

Model GL.iNet GL-MT6000
Architecture ARMv8 Processor rev 4
Target Platform mediatek/filogic
Firmware Version OpenWrt SNAPSHOT r25389-fe0081eecf / LuCI Master git-24.052.52717-06c0fbb
Kernel Version 6.1.79

I copy "config/wireless" from old router (Netgear R7800) to new router (GL-MT6000), because I not wish to re-enter the passwords (I have very long ones) on all devices.

Now How-To fix "Wireless is not associated" and "Device is not active" in LuCI?

See screenshot of errors/issues

(the black bars are the old SSID I wish to import)

thanks and have a happy day

Radio1 has two configurations that are enabled and conflicting; you can only have one.

Disable the one you do not need and restart radio1.

Radio0 just needs to be enabled.

1 Like

Please copy the contents of /etc/config/wireless here, replacing all SSIDs and PSKs with placeholders. Be sure to use the </> button in the editor toolbar to format the text correctly.

1 Like

here the config

cat wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option country 'CH'
        option cell_density '1'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option wpa_disable_eapol_key_retries '1'
        option encryption 'psk2'
        option ssid ‘sweffeefwr’
        option key ‘sdsdfds’
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option country 'CH'
        option cell_density '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option wpa_disable_eapol_key_retries '1'
        option encryption 'psk2'
        option ssid ‘adasdsdsds’
        option key ‘awdadeadaedsadsadsadsacscad’

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'ap'
        option ssid ‘asdasadadssacp'
        option encryption 'psk2'
        option key ‘asssaassasasa’
        option wpa_disable_eapol_key_retries '1'
        option network 'lan'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi'
        option channel '1'
        option band '2g'
        option htmode 'HE20'
        option disabled '1'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio3'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi+1'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option disabled '1'

config wifi-iface 'default_radio3'
        option device 'radio3'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

You should not overwrite the wifi-device sections at the very least.
The path variables would almost certainly be different between the two.

Really this is a recipe for disaster and your laziness is now costing you troubleshooting time.

This is not a file that you can copy over -- it is highly device dependent. You need to do the following:

rm /etc/config/wireless
wifi config

Then, you can take your earlier config and copy/paste the keys only into place.

2 Likes

Your screenshot shows that the wireless config is not pointing to the correct wireless radios (that's why it's saying "Generic unknown" for all your interfaces). Do what @psherman says to restore the /etc/config/wireless to its default state, then post its contents here. We can then tell you exactly what needs to be copied over and what can't.

# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi'
        option channel '1'
        option band '2g'
        option htmode 'HE20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi+1'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

To confirm -- this is the file after deleting the existing wifi file and then recreating it via wifi config, right?

If so, now you can configure your SSIDs -- feel free to copy/paste the SSID name and passphrase into place -- but only those fields.

1 Like

Oh, it is a bigger mess than I thought.
I missed from one totally different device to another.

1 Like

Try this, with the actual SSID/PSKs and not their placeholders:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi'
        option channel '11'
        option band '2g'
        option htmode 'HE20'
        option country 'CH'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi+1'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option country 'CH'

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'ap'
        option ssid ‘sweffeefwr’
        option encryption 'psk2'
        option key ‘sdsdfds’
        option network 'lan'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid ‘adasdsdsds’
        option encryption 'psk2'
        option key ‘awdadeadaedsadsadsadsacscad’
        option network 'lan'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'ap'
        option ssid ‘asdasadadssacp'
        option encryption 'psk2'
        option key ‘asssaassasasa’
        option network 'lan'

For future reference, the wireless settings you need to set on the new router are:

  • Country code (CH in this case)
  • WiFi channels
  • SSIDs
  • PSKs
  • Encryption types (psk2 in this case)

Everything else should be kept to their default values. Pay attention to which one is the 5 GHz radio and the 2.4 GHz radio.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.