I can't ping domains

Good evening,
I have successfully installed OpenWRT Snapshot from my router GUI (TP-Link Archer C6). As I discovered later, this version does not have a graphical interface (luci), which would be easy to install if I could connect to the internet; in fact I manage to ping the ip (1.1.1.1), but not the domains (www.openwrt.org), receiving as response "bad address". How can I solve? Thanks in advance and good evening.

if pinging works, but name resolution doesn't, it's probably a DNS issue.

what DNSes have you got set up ? what does /etc/resolv.conf contain ?

Thanks for the quick reply. I have set up a single DNS, that is 192.168.1.1. The resolv.conf file contains this:
search lan nameserver 127.0.0.1 nameserver ::1

What is 192.168.1.1?
Please post the output of the following commands, using the preformatted text button (</>).

uci show network; head -n -0 -v /etc/resolv* /tmp/resolv* /tmp/resolv*/*; \
nslookup openwrt.org localhost; echo ""; nslookup openwrt.org 192.168.1.1; \
echo ""; nslookup openwrt.org 8.8.8.8;

Redact the public IP addresses in your network configuration if any.

network.loopback=interface
network.loopback.device='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd0c:7f04:70f5::/48'
network.@device[0]=device
network.@device[0].name='br-lan'
network.@device[0].type='bridge'
network.@device[0].ports='eth0.1'
network.lan=interface
network.lan.device='br-lan'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.dns='192.168.1.1'
network.wan=interface
network.wan.device='eth0.2'
network.wan.proto='dhcp'
network.wan6=interface
network.wan6.device='eth0.2'
network.wan6.proto='dhcpv6'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='2 3 4 5 0t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='1 0t'
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface lan
nameserver 192.168.1.1
# Interface wan
nameserver 192.168.1.1
search home-life.hub
Server:         localhost
Address:        [::1]:53

** server can't find openwrt.org: REFUSED

** server can't find openwrt.org: REFUSED


Server:         192.168.1.1
Address:        192.168.1.1:53

** server can't find openwrt.org: REFUSED

** server can't find openwrt.org: REFUSED


Server:         8.8.8.8
Address:        8.8.8.8:53

Non-authoritative answer:
Name:   openwrt.org
Address: 2a03:b0c0:3:d0::1af1:1

Non-authoritative answer:
Name:   openwrt.org
Address: 139.59.209.225
uci delete network.lan.dns='192.168.1.1'
uci add_list network.wan.dns='8.8.8.8'
uci set dhcp.@dnsmasq[0].server='8.8.8.8'
/etc/init.d/dnsmasq restart
/etc/init.d/network restart
3 Likes

TFTP recovery https://openwrt.org/toh/start?dataflt[Model*~]=Archer+c6

1 Like

The 'DNS' directive in the network configuration indicates the upstream DNS to be used when that interface is up, not the DNS to be used by the clients on that network.

Ah ok, thanks for the explanation.

disable the firewall ?

Disable the filter, to start with.

But there's obviously a risk of damaged boot loader, because of the bad flash.

If that's the case, the only recovery would be a flash writer.

Then set your client's IP to something in the subnet, and try to access the IP.

well that won't work. you need to set it manually

Good evening, I finally managed to solve the problem. Now I have full access to the rpouter from SSH and the GUI. I have created a Wi-Fi connection but I have the problem described above: the Wi-Fi network is not working. I also tried pinging www.openwrt.org and it returns the "bad address" error message. I tried to issue the commands described above, but they didn't work. Do you have any other advice? Thanks in advance for your availability.

define this

from where ?

Sorry for my generality. Now the Wi-Fi works but is quite slow, despite having also enabled the 5 Ghz band, and some web pages freeze in the middle of loading. So I tried to connect via SSH to my router and ping the site www.openwrt.org, receiving the error message "ping: bad address: 'www.openwrt.org'" as a response. Do you have any suggestions to solve? Thanks in advance.