I cannot connect to serial port of my router

I have a Phicomm Ke2P router that I was using for 3-4 years. It is pretty old but it was never bottlenecking for my needs. Until now. I found a bug in its stock firmware so every time I set up port forwarding. My router cuts of the internet if I'm using custom DNS (more discussed here) .I don't want to buy a new souter, since I like the design and functionality of the current one. It has a slim aluminium body and only one RGB LED that can be turned off.
So I bought TTL to USB converter, soldered pins TX RD and GRD to its serial connector, connected it annnd I've got nothing at the output. I thought that I made a bad job soldering the pins, but that was not the case. The only thing I can do to get any output at all is to connect TX to RX and vice versa. And even then it is just unreadable junk of random characters.
I thought that maybe my TTL converter is broken so I decided to test it. I have connected it to a USB I left its pins unplugged. Tried to type into the console and nothing happened, as I was expecting. After that, I shorted the RX and TX pins and tried again, now with the output what was pretty good evidence that it is indeed working. It has to be something with a router, or connection, but I was able to find almost 0 documentation about this problem so that's why I'm here. It is my last hope before buying a new router.. Can someone guess why is this behaving like that?

Sorry if there are any grammar errors, I am not a native speaker.

I think you can refer to this other page about yor device, specifically to the serial parameters. Probably you are just omitting the baud rate (57600) and your serial terminal is using a different default value. This is a common cause for garbled output (and yes you need to cross TX-RX).


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.