I can only login into LuCI using Private Browsing mode with Firefox


I'm running:

TP-Link TL-WDR4300 v1
OpenWrt 19.07.3 r11063-85e04e9f46 / LuCI openwrt-19.07 branch git-20.136.49537-fb2f363

Since some previous update I can no longer login to using normal Firefox mode (currenlty it's 76.0.1 on Debian Sid).

I disable uBlock Origin, Ghostery, Privacy Badger, HTTPS Everywhere, DuckDuckGo Privacy Essentials, whitelist host in NoScript... Nothing helps. Well, only Private Browsing mode does.

Otherwise, I just get 403 and get back to same login page!

Firefox autocompletes password for both normal and private mode. Entering password manually makes no change.

This is raw headers of the response:

HTTP/1.1 403 Forbidden
Connection: Keep-Alive
Transfer-Encoding: chunked
Keep-Alive: timeout=20
X-LuCI-Login-Required: yes
Content-Type: text/html
Cache-Control: no-cache
Expires: 0
X-Frame-Options: SAMEORIGIN
X-XSS-Protection: 1; mode=block
X-Content-Type-Options: nosniff

Any ideas how to debug this?


Did you clear the cache?


Oh boy.. that's so embarrassing.. It did the trick! How I didn't thought of that...


1 Like

Sadly browsers tend to remember redirects basically forever (unless you clear the cache), that is a problem if they do change (e.g. when moving from the OEM firmware to OpenWrt or from HTTPS enabled luci back to plain HTTP).

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.