I can not connect brother printer wirelessly

I have an Internet of Shit device that doesn't support long and complex passphrases. I made a WLAN interface with short passphrase.

One of the traps with Printer wifi interfaces is that they support 2 different protocols.
In wireless networking terms, the first is ad-hoc and is often referred to as "Guest".
The router is bypassed and the print job can go directly from one wireless connection to the printer.

The second one is infrastructure and it goes through the router.

You can set separate WPA2/3 keys for ad-hoc and infrastructure. If you just set the key for ad-hoc and try to connect via infrastructure, infrastructure will fail to negotiate and establish a connection.

Thats the thing I try now.

Sorry for the OT, but what is that strange USB Type? What cable I need to buy to connect to MacBook (Apple Silicon)?

That is the original usb b connector. You can get either a usb c to usb b cable ( probably hard to find) or a usb c to a (female) adapter and a usb a to b cable (often called a usb printer cable).

1 Like

I have an old EPSON printer that can't connect to wifi because roaming is enabled, so I had to create a secondary wifi with roaming disabled. The printer can connect to the secondary wifi.

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'main'
	option encryption 'psk2+ccmp'
	option dtim_period '1'
	option wpa_group_rekey '86400'
	option key 'password'
	option ieee80211r '1'
	option reassociation_deadline '2000'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option ieee80211k '1'
	option time_advertisement '2'
	option time_zone '<+08>-8'
	option wnm_sleep_mode '1'
	option bss_transition '1'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'legacy'
	option encryption 'psk2+ccmp'
	option dtim_period '1'
	option wpa_group_rekey '86400'
	option key 'password'
	option network 'lan'