I can not connect brother printer wirelessly

MFC - L2710DW pritner ..if I connect via usb cable it works but even if I enter correct wifi password - it always give same error - wrong network key(wifi password)

when I connect through usb cable with my computer - it works fine.

Sometimes it gives error saying - check your network configuration

I have power cycle ..restarted and factory reset but same error ...I even copy pasted wifi password from windows 10 in to printer installation window - I am very sure am typing it incorrectly

when I see in openwrt oveview-status - briefly printer's mac id - shows up and under host it shows question mark - only briefly - but than it disappears and comes again and disappears like in cycle

I am positive - it is not able to get ip address in the lan am trying to connect it to - I have disabled mac id filter - what else I should do ?

so why do I get this error?

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board 
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

In addition to the above, keep an eye on logread ; logread -f.

…but in general, tcp/ip stacks and even more so WLAN modules used in printers are $NOT_GOOD, news at 11.

I know this isn't helpful to you, but I've been using that exact model of printer for several years with no problems. Make sure you're entering the password correctly. It's easy to enter the wrong letters/symbols using the printer interface.

Had similar problem with my old HP because the printer wifi hw stop working correctly. I forgot wifi and used USB.

1 Like

The only thing I can think of is you have set the minimum connection rate offered. This setting is found in the advanced tab in wifi settings. Try allowing for any connection rate.

I use brother MFC J430W. No problems connecting to access point on 2.4G although my printer is sitting right next to the access point.

You said advanced tab in wifi setting - but where do I choose that ? in printer physically or in router?

on your openwrt device

1 Like

Guys when I connect printer to computer wireless - it works ..it just does not work when I try to connect to router.

try to set wpa and non wpa2 maybe that.

This raises more questions than it answers. Define your wireless and your router here, maybe provide a diagram of your network and the complete config (as had been previously requested).

Given that WPA(1) is broken, it mustn't be used - ever.

In the absence of any config- or log files to go by, I would suggest to solve this issue the easy way - by connecting it via its wired ethernet port (or USB, if LAN isn't an option) instead.

--
Any device not supporting WPA2PSK/ CCMP without any specialties is broken and as good as no wireless at all.

2 Likes

Well broken or not i'm Just saying to check if that Is the point

There are a hundred things you could try, but sharing your network setup is the place to start. Otherwise we're just making guesses.

I'll leave this here for the next poor soul (and probably me) that goes on this quest:

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option key 'pppppppp'
	option ssid 'wwwwwww'
	option encryption 'psk2+ccmp'
	option disassoc_low_ack '0'
	option short_preamble '0'

option disassoc_low_ack '0' means you have checked or unchecked in luci? and same question for option short_preamble '0'

I have unchecked them and now the printer works

I've also set 802.11w Management Frame Protection to disabled.

I have a "Brother HL-1210w"

WLAN not working after upgrade to new GL-MT6000 router. Same passhrase and SSID as before.

My old router was R7800

cat etc/config/wireless

config wifi-device 'radio0'  
option type 'mac80211'  
option path 'platform/soc/18000000.wifi'  
option channel '1'  
option band '2g'  
option htmode 'HE20'  
option country 'CH'  
option cell_density '0'

config wifi-iface 'default_radio0'  
option device 'radio0'  
option network 'lan'  
option mode 'ap'  
option ssid ''  
option encryption 'psk2'  
option key ''  
option short_preamble '0'  
option disassoc_low_ack '0'  
option wpa_disable_eapol_key_retries '1'

config wifi-device 'radio1'  
option type 'mac80211'  
option path 'platform/soc/18000000.wifi+1'  
option channel '36'  
option band '5g'  
option htmode 'HE80'  
option country 'CH'  
option cell_density '0'

config wifi-iface 'default_radio1'  
option device 'radio1'  
option network 'lan'  
option mode 'ap'  
option ssid ''  
option encryption 'psk2'  
option key ''  
option short_preamble '0'  
option disassoc_low_ack '0'  
option wpa_disable_eapol_key_retries '1'

config wifi-iface 'wifinet2'  
option device 'radio1'  
option mode 'ap'  
option ssid ''  
option encryption 'psk2'  
option key ''  
option wpa_disable_eapol_key_retries '1'  
option network 'lan'

Try removing the last 3 lines below:

Your printer appears to be a 2.4GHz only device, and it says it supports WPA2 (AES) encryption. You may want to play with the encryption cypher options to see if one of those choices makes it work better.

If you can't get it to work, try resetting the printer's wifi settings and re-entering the credentials.

Meanwhile, likely unrelated... what is the purpose of the wifinet2 interface? It seems to be the same as your default_radio1 interface since both are on the same radio and both tied to the same network.

1 Like