I can' bring up my wifi device

root@OpenWrt:~# lsusb
Bus 001 Device 004: ID x:x Broadcom Corp. BCM43143 802.11bgn (1x1) Wireless Adapter
root@OpenWrt:~# ip link show
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN qlen 1000
    link/ether x:x brd ff:ff:ff:ff:ff:ff

Trying to bring it up by ifconfig wlan0 up and then ip link show still shows it as DOWN.

Since lsusb shows the device, that means drivers are in order? Any logs that can give me more insight on this device?

This chipset is poorly supported in OpenWrt. It should come up, though, but you will find that the performance will be really bad.

What device are you using?

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
root@OpenWrt:~# ubus call system board
{
        "kernel": "4.14.241",
        "hostname": "OpenWrt",
        "system": "ARMv7 Processor rev 5 (v7l)",
        "model": "Raspberry Pi 2 Model B Rev 1.1",
        "board_name": "raspberrypi,2-model-b",
        "release": {
                "distribution": "OpenWrt",
                "version": "19.07.8",
                "revision": "r11364-ef56c85848",
                "target": "brcm2708/bcm2709",
                "description": "OpenWrt 19.07.8 r11364-ef56c85848"
        }
}

network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix ':::::::/48'

config interface 'lan'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.10.90'
        option gateway '192.168.10.1'
        list dns '8.8.8.8'
        list dns '1.1.1.1'

config interface 'WiFi'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.1'
        list dns '1.1.1.1'
        list dns '8.8.8.8'

wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/soc/3f980000.usb/usb1/1-1/1-1.2'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key 'test123'
        option network 'WiFi'

dhcp:

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'WiFi'
        option leasetime '12h'
        option limit '150'
        option interface 'WiFi'
        option start '50'

Dropping firewall. Have not touched it and I can revisit if it still does not work after getting it up (kinda long for pasting).

The reason why I run OpenWRT 19 is that I'm planning on using another wifi device, and the latest kernel is not supported by the manufacturer. I have have gotten teh current wifi dongle to work with v20, but now I have some problems... maybe it's config?

The firewall, in this case, would not prevent the radio from coming up, but it would possibly cause issues with connectivity of the wifi devices if not configured properly.

What happens if you start with a fresh installation (offline from your main network), and simply enable wifi? Does it work?

This is a fresh install today :smiley:, I've only configured eth0 to static IP and no DHCP so I can connect it to my home network. Also ran opkg update and the changed dhcp, network and wireless config files

Is there some logs somewhere that I can read? Device log and interface logs probably

opkg update or opkg upgrade?
You modified quite a few things including creating a separate (routed) wifi network. I'm suggesting a fresh install with literally no changes except for enabling wifi to make sure it is working properly (and this would be offline relative to your main network).

I got this single line from dmesg grepping wlan0:

[ 2466.313896] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

Hmm... I'll give it a try tomorrow :slight_smile: