I bricked Xiaomi 4A gigabit Edition on the first hour


I own Mi Router 4A Gigabit Edition the Chinese version (from AliExpress).

I tried to update the router via OTA but it bricked because i lost power mid update and I wasted countless hours trying to flash a firmware into the router using “MIWIFIRepairTool” from the official Xiaomi website and also tried TinyPXE and Bootp TFTP but non worked, I used “miwifi_r4a_all_cddf4_2.28.69.bin” and the older version “miwifi_r4a_firmware_72d65_2.28.62.bin” (both from official sources) but to no avail, I followed the instructions exactly.. turned off anti-virus, changed the IP to and, connected the router to my pc via ethernet, pressed and held the reset button then connected the router to power till the router started flashing yellow and then used the tool.

The problem starts when the tool sends the firmware to the router, the router just flashes purple very fast (I heard that means the router didn’t accept the firmware because of U-boot)

Sadly the only thing happening when I power the router is solid yellow, I held the reset button for more than 10 seconds but nothing changes, no blue light, the only thing this router can do is flash yellow when I press and hold the reset button and plug in the power while holding the reset button.

Here is a video of the E-waste after pushing the firmware

Do you have a hardware flashing tool that you could hook up to the NOR flash directly, like e.g. one based on the CH341a-chipset?

Moved to the Installing and Using OpenWrt forum.

you got led blink yellow, that means your router still under the bootloader control, not bricked.

try to back to stock fw again.

Have you tried an older version 2.18.28.bin?

Thanks WereCatf for the reply,
I was considering buying the tool as last resort, but i thought maybe someone has easier solution.

Yes i did try the firmware, also the global firmware, the non-gigabit firmware, even R3G firmware.. the only difference is when i try 2.18.28.bin the router refuses the firmware instantly instead of a one second delay (solid yellow) compared to the newer versions

The router completely refuses every firmware i give it.. i gave it about 8 different .bin files but same issue

Maybe someone can still come up with something else. I tend to just flash the chip directly, so I do not have any knowledge of trying to recover Xiaomi firmware in any other way, though. If/when you decide to buy the tool, I can then help you repair the router's firmware with it, though.

Do you have a UART-to-USB tools to check the log info from Uart port when startup?

I ordered the tool.. it’ll take some time to arrive.
I appreciate your help <3

1 Like

Hi, everyone!
I am new for OpenWrt. I think I bricked my xiaomi R4A gigabit Version2 device.
I will need the followings? Could anyone please help directions to obtain those files?

  1. Xiaomi R4A Gigabit V2 (R4AGV2) factory firmware 2.30.20 bin file?
  2. Bootp/tftp-server BootP-DHCP Server ? (this guide)

Please help for directions !
Thank you so much!

I have successfully debricked my R4AV2 device using TinyPXE4A flashing 2.30.25.bin (NOTE: MiWifi Repair tool did NOT work)
(NOTE: Bin File Earlier than 2.30.20 WON"T work for V2)

hey there, i just tried TinyPXE4A with the bin file you provided but it didn't work (same issue).
is there something specific i need to do?


here's the chip if that would help, thanks.

First, you need to make sure your device version. The bin file 2.30.25 is for Xiaomi R4A v2 Gigabit Edition (R4AGv2) . That is a 2nd version because they updated their hardware. If yours is v1, you will need the earlier bin.

I think your router is the new version R4aV3 some settings and image versions are different

I also had this kind of purple glow during messing around with the router for first time ...

I did the following to fix don't know if it will work for your router ( my routers manufacture date was in 2020-11)

Remove the plug from your router

Hold the reset button while the adapter is removed

Keep holding

Then Attach the adapter again ( still hold )

Then it will flash fast yellow ( safe mode with tftp is enabled at this stage )

Drop your image using tftp server it will accept and flash yellow for 10 M then turn blue

Then reboot and go to router.miwifi.com and change the settings

Some references:

My R4AGv2 has this flash chip

Hey there I've got the same problem with my router i tried most of these bin file with pxe server idk what to do my devices is made in 2022 is there any way to fix it ?