I bricked my WRT1900AC and cant recover using tftp

I have a wrt1900ac that I was trying to install open wrt on and when I uploaded the bin file to the dd-wrt upgrade page somehow I managed to brick it. When I was able to get a ttl to usb cable I was able to successfully delete both nand partitions as instructed by this video https://www.youtube.com/watch?v=PZYXKAkuJ5w&t=643s&ab_channel=CROOKED. I knew I had screwed up when it didn't connect to the tftp server and download the files. I guess at this point I have a paperweight of a device but I'm not going to give up just yet. Has anyone used a JTAG cable to recover one of these before? I do board work on automotive computers and desolder some crazy-sized chips. I am willing to go to some length to save it if someone can explain to me another way to get a file on the flash memory.

If uboot is still functional, keep trying with tftpboot, otherwise look for kwboot based recovery information, mvebu is rather hard to brick (although you really tried).

As @slh states, this is a hard beast to brick.

Do you have access
to either partition?

Have you tried to revert to stock using the Linksys TFTP return to stock process?

Sorry about your bricked router. I have experience with serial cable debricking. Please see https://openwrt.org/toh/linksys/wrt1900ac for details at your convenience.


I have and there is no serial access

Please post HD photos of MB. https://openwrt.org/toh/linksys/wrt_ac_series documentation suggests serial availability.

Good luck.