I bricked my router trying to install openwrt. Archer C2

I'm new to openwrt and was trying to instsall it on my tp-link archer c2 A750 router.

I downloaded this firmware https://firmware-selector.openwrt.org/?version=23.05.3&target=ramips%2Fmt7620&id=tplink_archer-c2-v1

then went to the router control page and used the firmware update dialoge to install it.

The router restarted after awhile and never fully booted again. I tried to reset the router but it didn't work.

I'm not sure if there is a way to fix this or my router is dead now. I'll be glad for any pointers

You should be able to recover using the tftp recovery method. Instructions are here:
https://openwrt.org/toh/tp-link/archer_c2_ac750

You may be best of with the firmware image provided by TP-Link just to make sure everything is working properly with the tftp recovery process (fewer variables at play).

I enabled tftp in windows, downloaded pumpkin and started a server

I get a time out error whenever the router tries to grab the file

[05/24/24 22:50:07] 'ArcherC2V1_tp_recovery.bin' of type 'octet' is requested from 192.168.0.1
[05/24/24 22:50:12] Transmission of 'ArcherC2V1_tp_recovery.bin' is timed out
[05/24/24 22:50:12] Transfer of 'ArcherC2V1_tp_recovery.bin' was aborted
[05/24/24 22:50:22] Transmission of 'ArcherC2V1_tp_recovery.bin' is timed out
[05/24/24 22:50:22] Transfer of 'ArcherC2V1_tp_recovery.bin' was aborted

I've never used Windows or Pumpkin for this purpose (I've only used Mac (maybe also Linux), so I cannot comment on the errors you're seeing. Maybe try another tftp server?

I tried tftpd64
This time it starts transferring the file but at 5% I get also timeout

Connection received from 192.168.0.1 on port 2699 [25/05 08:45:19.939]
Read request for file <ArcherC2V1_tp_recovery.bin>. Mode octet [25/05 08:45:19.939]
OACK: <timeout=1,> [25/05 08:45:19.939]
Using local port 51766 [25/05 08:45:19.939]
TIMEOUT waiting for Ack block #867  [25/05 08:45:34.384]

Did you try disabling the Windows firewall completely?

I don't think the firewall is the problem since it starts sending the file and times out after around 5%. I tried disabling it anyway but it didn't make a difference.

There's tftp client in Windows, might want to try it, just to see if the image transfers completely, using it.

I tried with this command

tftp -i 192.168.0.1 PUT <binary file path>

I don't see any action when I reboot the router into recovery and after few seconds I get

 Connect request failed

Not what I meant.

Test the TFTP sever, by getting the image.

Tried again. I used tftpd64 to PUT the image and used the windows client to get it.
Worked.

Transfer successful: 6095176 bytes in 1 second(s), 6095176 bytes/s

Hi, did you try another LAN cable?
Do you see something on the archer LEDs when transfer aborts?
Could you reduce LAN Port Speed to 100 or 10 MBit on PC?
Do you have a (unmanaged) switch to add between your PC and Archer?
Edit: do you have an alternative power supply for your Archer?

I believe I totally broke my router :frowning:
I was trying to use different network speed and I accidentally passed an empty file to the router
And the router took the file immediatly and I can't get into recovery mode anymore

Is using a serial connection can fix it now ?!
if so, is there any wiki on how so since the only thing I can see on the router openwrt page is how to do the physical connection