I bricked my Linksys EA8300, any way of getting it back?

Unsatisfied with the Tx power of my Linksys EA8300, I decided, without knowing what I was doing, to put OpenWRT on it (Because haha it'll be easy). Obviously I did something wrong along the way (got the OpenWRT firmware for EA8300 and loaded it as a firmware update) and it's now dead in the water. The lights light up, and ethernet still works on the ports, but there's no wireless signal, no SSID showing up, and the page is inaccessible through ethernet. Insert Da Squad yell here. I've tried googling around but no luck for this model. I've tried the 30/30/30 reset but nothin. Is there anything I can do? I need help plz. Thanks.

P.S. Sorry, I'm new to this

@brownse10, welcome to the community!

  • Your device page notes that the currently available version of OpenWrt is a development snapshot. Snapshots don't have a web GUI unless you install it.
  • Wireless is disabled by default on Openwrt
  • There is no such thing as a 30/30/30 reset in modern OpenWrt
  • See: https://openwrt.org/toh/linksys/linksys_ea8300

Thanks, I missed that page. How can I go about easily reverting firmware to stock?

See section: OEM Firmware > Revert to Stock.

It's on the page linked above.

(FYI, if you're able to perform the work to revert to stock, you may wish to just install the web GUI and play around.)

okpg update
okpg install luci
1 Like

I appreciate the info, but this is way above my pay grade. I have zero experience with router flashing and the such. It's a ELI5 situation for me. :confused:

I see Linksys's TFTP utility, and my earlier attempts to flash firmware showed that I was able to ping the router...

Perhaps someone else can better assist you then. I'm not that comfortable with assisting someone in reverting a device I do not own.

In your case and skill level, my personal advice would be to:

To be clear, I don't think your router is bricked. I think it successfully flashed; and by default, you have no wireless and no GUI - that is expected. You'll need to learn to SSH to the command line to solve any of your current issues.

If you cannot SSH, then you'll have to use TFTP recovery (per the wiki page). That would require you to open the device and have a special 3.3 Volt TTL serial cable; and maybe even soldiering.

So personally, I would try web GUI first.



It seems that might be easier, I'll try that. Looking like it's possible thru PowerShell, so I think I might be able to figure it out.

Thanks a ton for your help.

1 Like

It’s a dual-firmware device. Just power it off three times in a row after it starts booting (~10 seconds after the lights first flash) and it will switch back to the “other” firmware. If you only flashed once, that will be OEM.

As I own three, I can tell you the wireless performance is comparable, but OpenWrt is more secure, more flexible, and doesn’t “phone home” like the Linksys firmware does.


Got LuCI installed, everything is back in order. Thanks alot!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.