I am Creating WPA2-PSK network in openwrt with fast transition. But Fast Transition makes ssid open instead of WPA2-PSK

Here is my wireless configuration

config wifi-device 'wifi1'
	option type 'qcawifi'
	option channel 'auto'
	option hwmode '11a'
	option txpower '20'

config wifi-iface
	option device 'wifi1'
	option network 'lan'
	option mode 'ap'
	option wds '1'
	option encryption 'psk2'
	option key '12345678'
	option ssid 'Roaming5Ghz'
	option mobility_domain 'ab12'
	option ieee80211r '1'
	option ft_psk_generate_local '1'
	option nasid '12346'

As soon as I write option ieee80211r '1' , it automatically opens the networks however I have applied encryption here.
And as soon as I remove the option ieee80211r then network becomes secure?

What am I doing wrong? Please guide me

'qcawifi' sounds like you're using some Qualcomm SDK (based on OpenWrt 15.05) with their own drivers.

1 Like

Yes, Then is it the only problem?

Well besides 15.05 being old, I have no idea how and if that SDK handles 802.11r. The FOSS ath9k driver does support 802.11r.

If your device is supported by OpenWrt itself, I'd recommend installing vanilla OpenWrt. Otherwise you'll need to find someone familiar with that SDK.