Hurricane electric IPv6 tunnel - behind ISP router

#1

Hi there,

I only got ipv4 from my isp. So I thought an ipv6 tunnel from HE would be neat.
A quick plan of my setup:
isp-router ----- openWRT-router ----- net a
----- net b
----- net c
----- net d

So I got an ISP-Router connected via an extra ipv4 network to my openWRT router.
I configure the IPV6-Tunnel on the openWRT router and i figure the tunnel would setup itself when i put in the ip adress from HE and the wan adress or the dydns of my internet connection s endpoints of the tunnel. But no.I got no global routed ipv6 adresses, so no ipv6 internet connection..
I read once that I need an direct WAN connection on my openwrt router.. Is that really the case?

If you had similar issues or know anything about this topic, please write a post :slight_smile:

greetings Sebastian

#2
4 Likes
#3

Better than a post, I wrote a howto :slight_smile:

Check the Setting up an IPv6 Tunnel with LuCI page that talks about creating an HE.net account, then configuring it on OpenWrt.

The instructions and configuration works just fine for me behind my ISP's DSL modem. Let me know if you have questions.

3 Likes
#4

@richb-hanover-priv
Maybe be missunderstood here.
I have a normal customer DSL connection from my ISP with a ipv4 only connection. It has a dynamic ip(v4)-adress which chages every 24 hours or so.
This ISP connection terminates to a router (avm fritz.box). This fritzbox is in network 10.0.10.0/24. In that Network a got my OpenWRT router. And on this router i want to end the tunnel. My clients are connected to that OpenWRT router.
(Here's a quick draw of my network https://drive.google.com/file/d/1EhWglFM2KEJcmNw5uGbirbzG5kYZU47G/view?usp=sharing )

Now i got though your howto, my clients got ipv6 adresses, but there is not connection to lets say to ipv6 .google .com. (ping6)

From what a got from here http://silmor.de/ipv6.tunnel.php I whould have to forward the protokoll 41 to my openWRT router, right? I doubt that fritz.box can do that...

#5

Yes, if fritzbox doesn't support 1:1 nat for protocol 41 then you could try configuring the openwrt router as dmz device if that's possible and hope it will enable NAT 1:1 for protocol 41.

2 Likes
#6

It appears that my own DSL router does forward protocol 41, so that's why it works. @mikma's advide may help your case.

I also note that my IPv4 address is relatively stable (the same for weeks at a time). You can force the 6in4 tunnel by going to a URL to force-update to the new IPv4 address. See "Re-establishing the Tunnel" in https://github.com/richb-hanover/OpenWrtScripts/blob/master/tunnelbroker.sh I should add that to the Howto.

Thanks!

1 Like