Huawei USB LTE Modem failing dhcp and routing

Hi All,

Having an issue with a little AR150 from gl.inet and using a USB huawei modem with it. The modem is a E5786-62a.

Modeswitch sucessfully runs against it and it presents a wwan0 interface, but it ends up with two issues, the first is that dhcp fails. Doing a bit of digging, its running this command, which is failing:

root@OpenWrt:/lib/netifd/proto# /bin/sh ./ dhcp teardown 4G_LAN {"proto":"dhcp","ifname":"wwan0","clientid":"root"} wwan0
Failed to parse message data

Couldn't quite figure out what is failing there in that script, but running udhcpc on the interface worked fine:

root@OpenWrt:~# udhcpc -i wwan0
udhcpc: started, v1.28.4
udhcpc: sending discover
udhcpc: read error: Network is down, reopening socket
udhcpc: sending discover
udhcpc: sending select for
udhcpc: lease of obtained, lease time 86400
udhcpc: ifconfig wwan0 netmask broadcast +
udhcpc: setting default routers:

Except that i cant create any routes to it. I get no error messages anywhere i can find when trying to do this but no route appears in the table (tried to add it via its ip address and via its device name), nothing is sent on syslog and nothing in dmesg:

root@OpenWrt:/lib/netifd/proto# ip route add via
root@OpenWrt:/lib/netifd/proto# ip route dev eth0 scope link  src dev wwan0 scope link  src dev br-lan scope link  src 

root@OpenWrt:~# ip route add default dev wwan0
root@OpenWrt:~# ip route dev wwan0 scope link  src dev br-lan scope link  src 

If i ping (the modems address), it responds.

I've tried with 17.01.6, 18.06.02 and the latest snapshot, all three do exactly the same thing.

Running on a generic linux ubuntu machine, it works ok. Anyone got any ideas why I might be getting those two issues (the second one is something I cant figure out a way around)?

I eventually figured out what was going wrong with the DHCP client.

Chrome in its infinite wisdom (or lack there of) was auto-filling one of the fields of the form (clientid) as "root". Suppose that could happen any time you go to the advanced tab of an interface really (chrome being "helpful" that is).

Still cant add routes though