Huawei E3372 on TP-Link Archer C5 with 17.01.4

I'm stuck getting my 4G Stick (Huawei E3372) to work.

Following several instructions on the net, I installed the neccessary packages and now I have that ouput from dmesg:

[   14.573602] usbcore: registered new interface driver usbserial
[   14.579586] usbcore: registered new interface driver usbserial_generic
[   14.586324] usbserial: USB Serial support registered for generic
[   14.679860] xt_time: kernel timezone is -0000
[   14.737884] cdc_ether 2-1:1.0 eth2: register 'cdc_ether' at usb-ehci-platform.1-1, CDC Ethernet Device, 0c:5b:8f:27:9a:64
[   14.749174] usbcore: registered new interface driver cdc_ether
[   14.786373] PPP generic driver version 2.4.2
[   14.807844] NET: Registered protocol family 24
[   14.821768] usbcore: registered new interface driver rndis_host

However, I have no additional interface showing up, and therefore I can't define it for WAN. "ifup wan" makes no change.

Can anyone please point me in the right direction?

including this one?

not yet, I tried now, however I do not have a device /dev/ttyUSB0 so I'm stuck in the first step (switch modem to provide NDIS using AT commands) (I tried using minicom on a Mac, however, I don't have the device /dev/ttyUSB0 on the Mac and not on the Archer C5).

I guessed, the E3372 may must be switched to operating mode first, so I tried running the HiLink-Setup that starts when I connect the stick to the Mac. But after that I still have no /dev/ttyUSB0