Https-dns-proxy breaks my local start up

hi, I have installed https-dns-proxy and it seems to work fine.Unfortunately the local start up no longer works since I installed it.I take this opportunity to post the configurations to make sure they are correct.

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	list server '/'
	list server ''
	list server ''
	option noresolv '1'
	option doh_backup_noresolv '-1'
	list doh_backup_server '/'
	option localuse '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'


config main 'config'
	option update_dnsmasq_config '*'
	option force_dns '1'
	list force_dns_port '53'
	list force_dns_port '853'

config https-dns-proxy 'dns'
	option resolver_url ''
	option listen_addr ''
	option listen_port '5053'
	option bootstrap_dns ',,2001:4860:4860::8888,2001:4860:4860::8844'

config https-dns-proxy
	option resolver_url ''
	option bootstrap_dns ',,2606:4700:4700::1111,2606:4700:4700::1001'
	option listen_addr ''
	option listen_port '5054'

this is my simple start up
mtkwifi reload

What "no longer works" ?

mtkwifi reload

so you're saying your DNS (re)configuration broke some wifi functionality for you ?

i think it needs time to start https-dns-proxy and it creates problems. i also tried with sleep 60, but it doesn't work

sleep 60 for what ?
the proxy, or the mtkwifi ?

try to provide less info, if possible.

for mtkwifi

Mental note to oneself: add sarcasm tags to all posts intended as sarcasms ...

frollic if i said that probably https-dns-proxy takes a long time to start, can it ever be possible that i added another sixty seconds of delay?

no idea what mtkwifi does, but try disabling the proxy autostart,
and start it manually in the local startup script, after mtkwifi is run.

no joy,i tried before and after starting mtkwifi also with delay

what exactly does mtkwifi do ?

what if you remove it all together, from the startup script, and run it manually via ssh ?

The issue is with the init script of https-dns-proxy, apparently it stalls the boot. The actual contents of rc.local are of little relevance for further diagnosis


so jow do you have a working solution,please

No, if the assumption is right then this is a bug in the package which needs to be fixed by the author

1 Like
/etc/init.d/https-dns-proxy enable
/etc/init.d/https-dns-proxy start
mtkwifi reload 
exit 0

Don't need the enable, start should be enough.

1 Like

no it's not

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.