[HowTo] Running Adguard Home on OpenWrt

I am not facing this issue. I am on stable OpenWrt 19.07.4. Package manager is working the way it normally does.

I found out in the end, that I needed to add the dns into the interface option in the section for DHCP server

Same issue for me on my X86_64.

This helped me setup my router with OpenWrt and AdGuardHome. Maybe this will help someone else.

I have a WRT-1900ACS running Davidc502 firmware. I had to install AdGuard to a usb flashdrive because of the lack of free memory. The usb drive is mounted to /mnt and while everything work perfectly, I can't install the luci-app-adguardhome, I'm getting the following errors because it's running from /mnt not /etc.

Installing luci-app-adguardhome (1.8-11) to root...
Configuring luci-app-adguardhome.
grep: /etc/crontabs/root: No such file or directory
grep: /etc/crontabs/root: No such file or directory
grep: /etc/crontabs/root: No such file or directory
grep: /etc/crontabs/root: No such file or directory
grep: /etc/crontabs/root: No such file or directory
awk: /etc/AdGuardHome.yaml: No such file or directory

someone can summarise the main differences between adguard and adblock? There's nothing on the general wiki ad blocking page https://openwrt.org/docs/guide-user/services/ad-blocking.
If I can ask more, I've read also about dns-over-https or dns-over-tls features offered by adguard home. Is it right? Does it mean that adguard home can replace dnscrypt2 and similar softwares too?

1 Like

I used OpenWRT on Redmi AC2100. I follow the instructions and set up the Adguardhome. However, it does not open with the reboot of the router, so I edit /etc/rc.local
Command: nano /etc/rc.local and add /opt/AdGuardHome/AdGuardHome (then save and exit)
The AdguardHome opened with the reboot of the router. However, the router led light on the router (system led) turned to RED (instead of blue) and the router cannot be rebooted from CLI or OpenWRT. I remove the line /opt/AdGuardHome/AdGuardHome in /etc/rc.local and unplugged the device. Then everything works normally. How this happens?

I had the same problem and I removed / opt / AdGuardHome / AdGuardHome
And everything is normal, but I cannot enter the program link 8080, and I can only access the Internet after I return the line / opt / AdGuardHome / AdGuardHome in its previous location.
Please help solve this problem



Hello everyone, i want to know, which file should i download to install it on my TP-Link Archer C7 (v5)? Thanks in advance.

opkg install adguardhome (in Snapshots).

1 Like

Any idea how to make adguardhome package to download the DNS block lists after startup? It never does, only after the set period for updating the lists.

Pros and cons of running AGH on OpenWrt vs a separate RPi (or similar)? Seems the RPi route would be better given the limited resources most OpenWrt routers have, but I see you guys doing it successfully, so that leaves me wondering.

no problems from daily using on months now, on espressobin board...

1 Like

Hi I am using Adblock for last one month in my Raspberry PI 4. The main issue I am facing is, I cannot configure a specific internal IP address, not to use safe search or not to filter a category. So I am thinking to install, Adguard Home also and then use openwrt firewall rules to redirect traffic from my specific IP address to redirect traffic to Adguard home. So please advice whether it will work these

  1. install Adguard Home along with Adblock. Will this work
  2. If so I should use the install package from the default software list in Luci or manually download and install
  3. What firewall rules, I should be using

Please help

1 Like

Can someone please help me on this.. posted 3 days ago..


I just discoverd to day on this OpenWRT wiki > Documentation, at the very bottom it mentions to disable rebind protection if you are using adguard home.

This is what I get when I tried that command:
root@OpenWrt:/opt# opkg install adguardhome

Unknown package 'adguardhome'.

Collected errors:

  • opkg_install_cmd: Cannot install package adguardhome
    Any further help, please.

What version do you have of OpenWrt? The package is on master and 21.02.

I think it is very, very important you note in your guide that the link you provided may not work for others. There are several different packages, based on different hardware, for adguardhome. I just spent 4 hours before I found the problem.

So this was a bit messy, but I managed to get it working hopefully, I get double queries in query log though, used method presented by gnashk for the most part, I have a WRT1900ACS, using the link that's for armv7 devices. Not sure what is up with those double queries, I set it up before and didn't get them, but had issues on reboot so tried stuff presented here. Also disabled rebind protection as per docs.