How unbrick TP-link Archer c6 Ver 3.2 EU only power led on

Hello everyone,
I managed to successfully brick my Archer C6 ver 3.2 EU router by flashing the wrong firmware onto it :grimacing: :stuck_out_tongue_closed_eyes:
Now when I turn it one, my computer does not even recognize that the ethernet cable is connected to anything and only the power LED stays on. I tried soft reset, hard reset, tftp transfer and nothing worked. I also tried to set my ip to but nothing. My computer says network cable is unplugged when the router is on and cable is attached.
Any ideas on how I can unbrick it without soldering a serial connection?
Thank you.
If I can't fix it myself I will have to take it to a repair man to solder the serial cable and flash the correct firmware.

TFTP recovery as described in

thank you frollic for your answer but as I said I've already tried that, My computer captures nothing from the router no matter what combination of buttons is pushed. The server application on my computer shows nothing in the log tab during the router's boot up.

if you did, you didn't read the instruction very well, but that's ok, it's your device ....
it also tells you to stop u-boot, so you'll need serial console access.

1 Like

I have read the instructions on that recovery post perfectly my man. It is you who didn't read my post very well Frollic. But thank you nevertheless.


but hey, whatever floats your boat ...

1 Like