How troubleshoot IPv6?

I have 18.06.2 on a WRT32X. IPv6 has never worked. If I remove the WRT32X then IPv6 works on my computer when connected directly to my modem. How do I troubleshoot this?

Edited for more information:
My modem is not a router.
Openwrt is not working as an IPv6 client. wan6 does not come up.

root@OpenWrt:~# ifstatus wan6
{
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcpv6",
        "device": "eth1.2",
        "data": {

        }
}

Is your modem also a router? You may need router advertisement relay/hybrid and proxy NDP relay/hybrid in this case. See dhcp ipv6 settings on lan interface.
If you can bridge the modem then it's preferred and in this case you don't need above relays.

There are two separate things:

Test ipv6 connectivity first from the router itself. ping6, traceroute6 from the SSH console.

And check from your modem's settings, if it has ipv6 configuration.

1 Like

My modem has no settings that I can configure.

Is my modem a router? I don't think so. An IPv4 client connected to it leases an Internet IPv4 address from it (67.87.xx.xx) as opposed to a LAN address.

tcpdump on eth1.2 for ipv6 packets will show you what kinds of communications are going on

Openwrt is not working as an IPv6 client. The WAN6 interface does not come up so unsurprisingly ping6 does not work.

ping6: sendto: Permission denied

Except for AP SSID via Luci, I configured nothing with netowrking. /etc/config/network already looks like the suggested configuration from the user guide.

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

I see this. I don't know what it means:

tcpdump -i eth1.2 -vv ip6
tcpdump: listening on eth1.2, link-type EN10MB (Ethernet), capture size 262144 bytes
10:22:31.786139 IP6 (flowlabel 0xec633, hlim 1, next-header UDP (17) payload length: 114) fe80::6238:e0ff:fec9:7a68.546 > ff02::1:2.547: [bad udp cksum 0xba74 -> 0x73df!] dhcp6 solicit (xid=88c71 (elapsed-time 65535) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_82 opt_83 opt_94 opt_95 opt_96 server-unicast) (client-ID hwaddr type 1 6038e0c97a68) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
10:24:29.056146 IP6 (flowlabel 0xec633, hlim 1, next-header UDP (17) payload length: 114) fe80::6238:e0ff:fec9:7a68.546 > ff02::1:2.547: [bad udp cksum 0xba74 -> 0x73df!] dhcp6 solicit (xid=88c71 (elapsed-time 65535) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_82 opt_83 opt_94 opt_95 opt_96 server-unicast) (client-ID hwaddr type 1 6038e0c97a68) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
10:26:42.176146 IP6 (flowlabel 0xec633, hlim 1, next-header UDP (17) payload length: 114) fe80::6238:e0ff:fec9:7a68.546 > ff02::1:2.547: [bad udp cksum 0xba74 -> 0x73df!] dhcp6 solicit (xid=88c71 (elapsed-time 65535) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_82 opt_83 opt_94 opt_95 opt_96 server-unicast) (client-ID hwaddr type 1 6038e0c97a68) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
10:28:34.816143 IP6 (flowlabel 0xec633, hlim 1, next-header UDP (17) payload length: 114) fe80::6238:e0ff:fec9:7a68.546 > ff02::1:2.547: [bad udp cksum 0xba74 -> 0x73df!] dhcp6 solicit (xid=88c71 (elapsed-time 65535) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_82 opt_83 opt_94 opt_95 opt_96 server-unicast) (client-ID hwaddr type 1 6038e0c97a68) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))

This means that your router is requesting on DHCPv6, but nothing is answering it.

Not sure why your ISP isn't answering. Have you tried resetting the config on the router? I have found the default config to work pretty well with IPv6 enabled ISPs.

I now suspect my ISP (edit: Optimum Online NJ, USA) does not have DHCPv6 and my Windows 7 computer just works with IPv6 anyway for reasons. I think my OpenWrt troubleshooting should be on hold until I find those reasons (which is out of scope for this forum.) Thanks everybody for the help!

1 Like
  • Had you ever received IPv6 from your ISP?
  • Are you referring to some local IPv6 address - because Windows will do that?

Perhaps you should just call your ISP and ask them. That would save a lot of "OpenWrt troubleshooting time."

wasn't windows using Teredo by default at one point... it was kinda a janky ipv6 tunnel thing that kinda sorta worked.

1 Like