How to Wake on lan?


My setup:

  1. FreeNAS (B360M Pro4 motherboard),
  2. router_2, OpenWrt, tp-link Archer c6 v2 EU,
  3. router_1, OpenWrt, Netgear r6220,, dhcp server.

1 --- lan, Ethernet attached --- 2 --- lan, Ethernet attached --- 3

both 2 and 3 have luci-app-wol installed.

Wol doesn't work.

My freenas is capable of waking up on lan cause I managed to wake it with this tool

With these settings it wakes up:image

I have tried many things before posting, thank you all in advance.

Which is the configuration you are using?

What do you mean by "configuration"?

my network configuration?
It is: router_1 connected with Ethernet cable in the same lan to router_2 and router_2 is connected with Ethernet cable in the same lan to freenas

I don't think i've understood your question though.

I have already read your comments here. i have used these commands

/usr/bin/etherwake -D -b "70:85:C2:8E:C4:2D"
/usr/bin/etherwake -D -i "br-lan" -b "70:85:C2:8E:C4:2D"
/usr/bin/etherwake -D -i br-lan -b 70:85:C2:8E:C4:2D

They don't work.

And just for fun i tried so many more but nothing

The page you posted has some options and an example, so I am asking which ones are you using.

Keep in mind that the default port of the wol is different of the tool you are using.

Try /usr/bin/etherwake -i br-lan 70:85:c2:8e:c4:2d

WOW, it was really an issue of capital letters in the command.

the command with the MAC address in lowercase worked!

/usr/bin/etherwake -i br-lan 70:85:c2:8e:c4:2d

I would like to report that luci-app-wol has a bug in it as it sends the command with the capital letters!

1 Like

Indeed etherwake needs MAC address in minor case. I use etherwake in scripts, never in GUI.
If you wish to issue a bug report you can do on this link. Not clear who the maintainer is, according openwrt website it says "common LuCI maintainers".

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.