How to VDSL with VLAN

Hi folks, I'm a newbie to OpenWRT and broadband in general. I managed to configure the VDSL connection but I wouldn't know how to "do the rest of the work" so that the internet connection works. I think the crux of the problem is that my ISP requires 802.1p 0 and/or 802.1q 835. How to do it?

The config/network can help?

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd25:adb2:d65c::/48'

config atm-bridge 'atm'
	option encaps 'llc'
	option nameprefix 'dsl'
	option vci '35'
	option vpi '8'
	option atmdev '0'
	option unit '0'
	option payload 'routed'

config dsl 'dsl'
	option annex 'a'
	option tone 'av'
	option ds_snr_offset '0'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ip6assign '60'
	option ipaddr '192.168.8.2'
	option netmask '255.255.0.0'

config device
	option name 'dsl0'
	option macaddr '14:cc:20:51:16:53'
	option ipv6 '0'
	option mtu '1500'

config interface 'wan'
	option device 'dsl0'
	option proto 'pppoe'
	option username 'benvenuto'
	option password 'ospite'
	option ipv6 '0'

https://www.google.com/search?q=openwrt+set+vlan+on+wan

ecc ....

Probably by replacing the above with

option device 'dsl0.835'

0 is already the default priority for VLAN tags in Linux IIRC.

1 Like