How to use OpenWrt as a wi-fi repeater using a different SSID

This is because you cannot have the same subnets on either side of a routing engine -- they have to be unique because otherwise there would be ambiguity. Imagine if you were sitting between two people with the same name and you had an envelope marked with that name that you were supposed to hand to one of them (but not the other)... how would you know who to give it to if they have the same name.

What is the subnet of your upstream router (A)?
What are you setting for your downstream (B)?
What exactly are you doing when you configure the wifi? (please be specific).

1 Like

i see ok that makes sense.
And if i understand correctly, the subnet of A is 192.168.1.1 and of B i set it on 192.168.2.1

For the wifi i basically do what this guide says, at least this last time before resetting it yet again https://openwrt.org/docs/guide-user/network/wifi/relay_configuration#using_nat
I did the using nat thing only because they relayd thing sounded too complex to be the thing i want to do.
Then after that i just create a new acess point and no matter if i bind it to a new "name of the network" or to the new name of the network + the wlan from the A wifi access point or what, also if i bind them to different firewall ranges or whatnot i even had all connections on the same range at some point and set all as accept to see if it was that but same result: both the connection to A and the access point B break unless i disable one of them so i dont know what's going on, maybe i should try an older version of OWRT?

you don't want to use relay for this... all you need to do is create a new network interface (suggest: 'wwan') with proto DHCP and associated with the 'wan' firewall zone. Then create a new sta mode connection on your wifi radio, associate it with the wwan network.

That should be all you need to do.

but wouldnt that not work? like its getting the internet from wwan. like wwan is the connection to AP A, then wwan1 is the access point B from this router, so if they arent in the same firewall they shouldnt be able to communicate to one another right?

also forgot to mention when the access points break on the AP A connection says wirles is not associated, which sounds like an issue from the wireless side of things and not the firewall or whatnot, i really dont get any of this, i'll try to do what you said to do, i think i understand, and see if it does work, maybe im just overcomplicating this rip

Router A is providing a network that is available on an SSID called "wifi-A". Router B connects to the SSID "wifi-A" as a client ('sta' mode) where "wifi-A" is the upstream/WAN network for Router B (router B's 'wwan'). Because this is the upstream network for router B, wwan is part of the wan zone.

Router B has a lan and provides a wlan with SSID ('ap' mode) called "wifi-B" to which clients connect. The lan network will be part of the lan zone in the firewall.

The fastest way to achieve the goal is to reset your router to defaults, then change the lan subnet as previously discussed, and then follow my directions here:

ok im gonna do that but i dont know what to do on the wireless zone of the webui, which one do i associate with which network? or should both be on the same one? or unspecified?

I'm not sure I am following... I just explained everything;

  1. create a new network called 'wwan' with proto dhcp and then associate it with the wan firewall zone.
  2. go to wifi and create a new STA mode connection (with network wwan) and then associate it to the wifi-A network.
  3. edit the existing AP mode configuration (which should be there by default and associated with the lan network) to enable wifi (set an SSID and password, enable the wifi).

That's all you need to do.

Ok now i understand help, i was just now about to do the second step and was a bit confused, hopefully i manage to properly set it up now thank you !!

ok nvm still doesnt work, like it doesnt care what i do the moment i got more than one wireless anything going the stuff refuses to work ?? like the wwan interface keps saying the device is not present and when i go to network all it says is that it's disabled but it is enabled ? im very confused

Maybe some screen grabs? Or better yet, text config files:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

fwiw, have you studied this wiki page?
https://openwrt.org/docs/guide-user/network/wifi/connect_client_wifi

Also I note the AD1018 is a single band Broadcom device. Perhaps that is why you are having issues with enabling client and AP on same radio ?

See warning at top of device page.
https://openwrt.org/toh/sercomm/ad1018
OpenWrt and Broadcom wifi is NOT best combination imho.

ok here are the config files and also the log since my first login if it helps, maybe its some weird limitation of this router?

network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd85:4af0:5c50::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 8t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 8t'

config interface 'wwan'
        option proto 'dhcp'
        option device 'radio0.network2'

wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0/bcma0:1'
        option band '2g'
        option channel 'auto'
        option legacy_rates '1'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'potat'
        option encryption 'psk'
        option key 'xxxxxxxxx'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'sta'
        option ssid 'BLM'
        option encryption 'psk-mixed'
        option bssid 'EC:xx:xx:xx:xx:xx'
        option key 'xxxxxxx'
        option network 'wwan'

dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

firewall


config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'
        list network 'wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

and log:

Sat Sep  3 03:01:08 2022 user.info : luci: accepted login on / for root from 192.168.1.118
Sat Sep  3 03:03:56 2022 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Sat Sep  3 03:03:56 2022 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Sat Sep  3 03:03:56 2022 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 1 addresses
Sat Sep  3 03:03:56 2022 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sat Sep  3 03:03:57 2022 daemon.notice netifd: Interface 'lan' is now down
Sat Sep  3 03:03:57 2022 kern.info kernel: [  521.032742] br-lan: port 1(eth0.1) entered disabled state
Sat Sep  3 03:03:57 2022 kern.info kernel: [  521.076330] device eth0.1 left promiscuous mode
Sat Sep  3 03:03:57 2022 kern.info kernel: [  521.080956] device eth0 left promiscuous mode
Sat Sep  3 03:03:57 2022 kern.info kernel: [  521.085949] br-lan: port 1(eth0.1) entered disabled state
Sat Sep  3 03:03:57 2022 daemon.notice netifd: Interface 'lan' is disabled
Sat Sep  3 03:03:57 2022 daemon.notice netifd: Interface 'lan' has link connectivity loss
Sat Sep  3 03:03:57 2022 daemon.notice netifd: Interface 'lan' has link connectivity
Sat Sep  3 03:03:57 2022 kern.info kernel: [  521.248099] br-lan: port 1(eth0.1) entered blocking state
Sat Sep  3 03:03:57 2022 kern.info kernel: [  521.253630] br-lan: port 1(eth0.1) entered disabled state
Sat Sep  3 03:03:57 2022 kern.info kernel: [  521.260154] device eth0.1 entered promiscuous mode
Sat Sep  3 03:03:57 2022 kern.info kernel: [  521.265047] device eth0 entered promiscuous mode
Sat Sep  3 03:03:57 2022 kern.info kernel: [  521.361806] br-lan: port 1(eth0.1) entered blocking state
Sat Sep  3 03:03:57 2022 kern.info kernel: [  521.367449] br-lan: port 1(eth0.1) entered forwarding state
Sat Sep  3 03:03:57 2022 daemon.notice netifd: Interface 'lan' is enabled
Sat Sep  3 03:03:57 2022 daemon.notice netifd: Interface 'lan' is setting up now
Sat Sep  3 03:03:57 2022 daemon.notice netifd: Interface 'lan' is now up
Sat Sep  3 03:03:58 2022 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Sat Sep  3 03:03:58 2022 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Sat Sep  3 03:03:58 2022 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 1 addresses
Sat Sep  3 03:03:58 2022 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sat Sep  3 03:03:58 2022 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Sat Sep  3 03:03:58 2022 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Sat Sep  3 03:03:58 2022 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 1 addresses
Sat Sep  3 03:03:58 2022 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sat Sep  3 03:03:58 2022 daemon.err odhcpd[1621]: Failed to send to ff02::1%lan@br-lan (Address not available)
Sat Sep  3 03:03:59 2022 kern.info kernel: [  522.785955] bcm63xx_enetsw bcm63xx_enetsw.0: link DOWN on LAN1
Sat Sep  3 03:04:00 2022 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Sat Sep  3 03:04:03 2022 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq[1]: started, version 2.86 cachesize 150
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq[1]: DNS service limited to local subnets
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-cryptohash no-DNSSEC no-ID loop-detect inotify dumpfile
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.2.100 -- 192.168.2.249, lease time 12h
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq[1]: using only locally-known addresses for test
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq[1]: using only locally-known addresses for local
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Sat Sep  3 03:04:04 2022 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 1 addresses
Sat Sep  3 03:04:04 2022 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sat Sep  3 03:04:12 2022 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Sat Sep  3 03:04:12 2022 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Sat Sep  3 03:04:12 2022 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 1 addresses
Sat Sep  3 03:04:12 2022 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sat Sep  3 03:04:33 2022 kern.info kernel: [  557.105978] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on LAN1, 100Mbps, full-duplex
Sat Sep  3 03:05:08 2022 user.info : luci: accepted login on / for root from 192.168.2.2
Sat Sep  3 03:12:19 2022 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0-1) --> new PHY
Sat Sep  3 03:12:19 2022 kern.info kernel: [ 1023.445786] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
Sat Sep  3 03:12:20 2022 kern.info kernel: [ 1023.860299] br-lan: port 2(wlan0-1) entered blocking state
Sat Sep  3 03:12:20 2022 kern.info kernel: [ 1023.866081] br-lan: port 2(wlan0-1) entered disabled state
Sat Sep  3 03:12:20 2022 kern.info kernel: [ 1023.872792] device wlan0-1 entered promiscuous mode
Sat Sep  3 03:12:20 2022 daemon.notice hostapd: ACS: Automatic channel selection started, this may take a bit
Sat Sep  3 03:12:20 2022 daemon.notice hostapd: wlan0-1: interface state UNINITIALIZED->ACS
Sat Sep  3 03:12:20 2022 daemon.notice hostapd: wlan0-1: ACS-STARTED
Sat Sep  3 03:12:21 2022 daemon.notice netifd: radio0 (6389): ip: SIOCSIFFLAGS: Resource busy
Sat Sep  3 03:12:21 2022 daemon.notice netifd: radio0 (6389): Interface 1 setup failed: IFUP_ERROR
Sat Sep  3 03:12:21 2022 daemon.notice netifd: Wireless device 'radio0' is now up
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:12:30 2022 daemon.err hostapd: ACS: Survey data missing
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:12:30 2022 daemon.err hostapd: ACS: Survey data missing
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:12:30 2022 daemon.err hostapd: ACS: Survey data missing
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:12:30 2022 daemon.err hostapd: ACS: Survey data missing
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:12:30 2022 daemon.err hostapd: ACS: Survey data missing
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: wlan0-1: ACS-COMPLETED freq=2412 channel=1
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: wlan0-1: interface state ACS->ENABLED
Sat Sep  3 03:12:30 2022 daemon.notice hostapd: wlan0-1: AP-ENABLED
Sat Sep  3 03:12:50 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:12:54 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:13:00 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:13:20 2022 kern.info kernel: [ 1084.118355] device wlan0-1 left promiscuous mode
Sat Sep  3 03:13:20 2022 kern.info kernel: [ 1084.123387] br-lan: port 2(wlan0-1) entered disabled state
Sat Sep  3 03:13:21 2022 daemon.notice hostapd: Remove interface 'wlan0-1'
Sat Sep  3 03:13:21 2022 daemon.notice hostapd: wlan0-1: interface state ENABLED->DISABLED
Sat Sep  3 03:13:21 2022 daemon.notice hostapd: wlan0-1: AP-DISABLED
Sat Sep  3 03:13:21 2022 daemon.notice hostapd: wlan0-1: CTRL-EVENT-TERMINATING
Sat Sep  3 03:13:21 2022 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Sat Sep  3 03:13:21 2022 daemon.notice hostapd: nl80211: deinit ifname=wlan0-1 disabled_11b_rates=0
Sat Sep  3 03:13:21 2022 daemon.notice hostapd: nl80211: Failed to remove interface wlan0-1 from bridge br-lan: Invalid argument
Sat Sep  3 03:13:21 2022 daemon.notice netifd: Wireless device 'radio0' is now down
Sat Sep  3 03:13:24 2022 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0-1) --> new PHY
Sat Sep  3 03:13:24 2022 kern.info kernel: [ 1088.335526] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
Sat Sep  3 03:13:25 2022 kern.info kernel: [ 1088.728740] br-lan: port 2(wlan0-1) entered blocking state
Sat Sep  3 03:13:25 2022 kern.info kernel: [ 1088.734361] br-lan: port 2(wlan0-1) entered disabled state
Sat Sep  3 03:13:25 2022 kern.info kernel: [ 1088.740973] device wlan0-1 entered promiscuous mode
Sat Sep  3 03:13:25 2022 daemon.notice hostapd: ACS: Automatic channel selection started, this may take a bit
Sat Sep  3 03:13:25 2022 daemon.notice hostapd: wlan0-1: interface state UNINITIALIZED->ACS
Sat Sep  3 03:13:25 2022 daemon.notice hostapd: wlan0-1: ACS-STARTED
Sat Sep  3 03:13:26 2022 daemon.notice netifd: radio0 (6670): ip: SIOCSIFFLAGS: Resource busy
Sat Sep  3 03:13:26 2022 daemon.notice netifd: radio0 (6670): Interface 1 setup failed: IFUP_ERROR
Sat Sep  3 03:13:26 2022 daemon.notice netifd: Wireless device 'radio0' is now up
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:13:35 2022 daemon.err hostapd: ACS: Survey data missing
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:13:35 2022 daemon.err hostapd: ACS: Survey data missing
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:13:35 2022 daemon.err hostapd: ACS: Survey data missing
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:13:35 2022 daemon.err hostapd: ACS: Survey data missing
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:13:35 2022 daemon.err hostapd: ACS: Survey data missing
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing channel time
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: ACS: Survey is missing RX and busy time (at least one is required)
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: wlan0-1: ACS-COMPLETED freq=2412 channel=1
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: wlan0-1: interface state ACS->ENABLED
Sat Sep  3 03:13:35 2022 daemon.notice hostapd: wlan0-1: AP-ENABLED
Sat Sep  3 03:13:45 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:13:45 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:14:07 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:15:30 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:16:04 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:16:04 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:16:04 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:16:16 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:16:36 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:16:36 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:16:41 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:16:49 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:17:04 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:17:06 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:17:06 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:17:06 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:17:06 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:18:00 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:18:10 2022 daemon.notice hostapd: handle_probe_req: send failed
Sat Sep  3 03:18:11 2022 daemon.notice hostapd: handle_probe_req: send failed

I think i tried to do a couple of things more after i saw it didnt work like set the device needed on the wwan interface bc it didn't have any. I tried reading throguh everything i just pasted here but i cant seem to see anything wrong except for how the log says that a lot of stuff is getting disabled or blocked
(also ignore the date/time becaause i didnt even configure it yet)

remove the option device line.

Is the upstream network using psk-mixed? Is it able to connect?

Did you set the country code?

Also, @bill888 raises a good point about the radio -- it may not be capable of running AP and sta mode simultaneously.

i didnt see @bill888 message til now, but yeah i studied that page and when i just connect to the wifi network it works all right, that was the first thing i tried, i tried setting the country code and leaving it on driver default and none of those options do anything different in any scenario, and i thought limited wifi was just having bg and no n compatibility? but honestly not surprised if it doesnt let me have several APs, i might try to have two acess points at the same time to see what happens if i cant get it to work after changing what you mentioned

Btw earlier the interface wwan didnt have the device line, i added it later when i saw it wasnt working as soon as i hit save and apply after following your instructions,

rn i dont have the country code set, but i guess i'll try now but im sure that wont be it since i was able to connect earlier without that set several times, like, on the webui it literally says disabled, not like "cant connect" or whatnot. will update you in a second

just did those changes, i also tried to disable wi-fi B and see if it could connect to A and it did btw, but then when i enable wi-fi-B, wi-fi a gets disabled and B stays in a weird state of --dBm and no info whatsoever, on interfaces it all looks good except for wwan (wi-fi b) that says Network device is not present
edit: another thing I've noticed is that the moment i enable the second wifi, the one this router creates aka wi-fi b, wwan/wlan0/wi-fi a disappears from the devices page. i think this may very well be a limitation of broadcom then, sadly, it seems it's all the Spanish ISPs like though oof. Is ther a way to bypass this maybe using relayd or some other extra software? if not i guess i'll give up and find a better use for this piece of e-waste tbh

edit2:
tried disabling wi-fi a and enabling wi-fi b, i can see on my phone its working, so then i tried to add another access point with a different name, it breaks again even the wi-fi led turns off (i forgot to mention but this happens too when i tried the wi-fi a +wi-fi b thing from earlier), so yeah i think by now its 100% a limitation, i guess i can just hope that over time maybe some of the developers are able to add support for several APs or there's a way to bypass it somehow, thanks for all the help and sorry to have waster both of your time. at least now i know i wasnt messing up big time its just that the thing can't do it

This is a hardware limitation. The dev team will not be able to add support for a feature that is hardware limited.

There are many other chipsets that are supported by openwrt and have the ability to do simultaneous ap+sta mode (or multiple ap). Or, a device with multiple radios will also be able to do this (one radio as sta, the other as ap).

what? you can actually do WDS on the official firmware I thought it was just software based :frowning:

and yeah i know but that'd mean buying hardware and i was hoping to reuse this router since i had it lying around, guess i could check some 2nd hand stores/websites and see if i can get one that supports this for cheap

In that case, the issue may be about closed source drivers. And in that situation, the devs cannot replicate all the functionality because of the proprietary nature of the drivers and chip sdk.

yeah i thought that might be the case but i mean until recently-ish it was impossible to even install openwrt on this without hardware mods and now its easier so i thought there might be hope for it to evolve and maybe someday get this functionality but tbh its a pretty useless router so it wouldnt be worth it and the amount of work needed to be able to reverse engineer close sourced drivers for this would be better spend literally anywhere else.

Also, i actually found a lot of routers for 5-10€ on a 2nd hand website, many are from isps so they have broadcom SoCs but maybe some dont, or they have an option to do this out of the box so i guess im gonna be looking for one and see if its worth the money. I marked the thread as solved already too since theres nothing left to try tbh. thanks for your help

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.