How to upgrade from DD-wrt to LEDE?Buffallo WHR-HP-G300N

Hello to all have this thing and wanna somehow remove DD-WRT firmware and install LEDE,so what step for reinstall?:relaxed:with linux and terminal using is not problem.

Look in the DD-WRT forum ;- )

From that forum send here to this forum :smile:

Keep rollin ;- )

Hello,again i here,still no lucky to put LEDE in this buffalo,what i tried,install stock user friendly firmware from official website,no lucky,after that tried install pro firmware also from buffalo website,also no lucky.:unamused: what tried next i dont know.Just wanna ridoff dd-wrt and install LEDE.

The procedures provided in the links should work, if not you are doomed to dd-wrt. Could be worse ;- )

Found a little solution,but i dont know if it works gone try tommorow on virtual box+linux lite and we will see.:smiling_imp:

The second link Doppel-D provided over in dd's forum looks like it has a much simpler solution in case you haven't tried it yet -

> ( Updated Sep 2015 ) DD-WRT web interface can be used to upgrade to the Chaos Calmer 15.05 release (openwrt-15.05-ar71xx-generic-whr-hp-g300n-squashfs-factory.bin)

So maybe flashing Chaos and then flashing LEDE from chaos might work.

Tried all ways and chaos,and lede,via winscp and via tftp,i think i stucked with dd-wrt to eternity.:sweat_smile:

I used ttl cable to flash from dd-wrt to lede.

I have a WZR-HP-G300N that I brought from DD-WRT to OpenWrt about 3 years ago. Below are my notes. Sorry, I do not recall much about this event, but looking at my notes it appears that the gist is to wget the firmware to the router and use mtd -r write to install it. Hope this helps.


Enable LAN on PC
Connect PC LAN to Router LAN
Connect router WAN to a LAN port on your primary router

reset Router via DD-WRT 30\30\30
Reboot router
Enter new user and password

Access router and enbale SSH under Services=>Services
No other config is needed.

Verify router has a WAN address.  If not release\renew IP from Status=>WAN or reboot router.

Access router via putty at (port 22)
NOTE: a warning will be presented alerting user about security. => YES

User: root
Pass: password set after router reset\reboot
NOTE: username is not the user set after reset\reboot

cd /tmp
You will see a progrss bar indicating the status of the download

mtd -r write openwrt-ar71xx-generic-wzr-hp-g300nh-squashfs-sysupgrade.bin linux
You will see a message "Unlocking Linux
Followed by
Writing from "file name" ... [w]

Putty fatal Error
Server unexpectedly closed network connection

Router lite flashes
After a few minutes the light will turn solid

ipconfig /release
ipconfig /renew

Clear Browser cache
NOTE: IP will have changed

Open browser and enter
LuCi should open
User: root
Pass: [blank] =>

That maybe works,i think is possible put barrier breaker with winscp into router /tmp folder?why need to do 30/30/30 on ddwrt,whats unlocks?

looks like RangerZ advice worked,now buffalo using LEDE :slight_smile: i"m happy for that.But another problem is that i not can reach that buffalo behind other router,network scheme is this --ISP--->TP-LINK MR3220 with DHCP-->Buffallo with LEDE working as switch,how fix situation,that i behind MR3220 can do configuration on Buffalo?Internet in to buffalo coming via WAN port(blue hole).

Glad to here my notes helped. Maybe you can "freshen" up the process a bit with your experience.

Without knowing what you have done to configure the Buffalo, and if you are using the blue WAN port, I would guess you have a Router behind a Router. If you want to place your buffalo behind the MR3220 and it is doing your LAN's DHCP, you probably want to configure your Buffalo as a "Dumb AP"

Actualy yes in scheme MR3220 is main network device and buffalo is second,wich is working like switch but i wifi disabled,just dumb router/switch.[quote="RangerZ, post:11, topic:2889"]
cd /tmp
You will see a progrss bar indicating the status of the download
mtd -r write openwrt-ar71xx-generic-wzr-hp-g300nh-squashfs-sysupgrade.bin linux
You will see a message "Unlocking Linux
This way is worked,but not all,because i don seen download process,but firmware putted via winscp SCP protocol,and mtd -r write option firmware write,but showed that "Linux is not supported",still after reboot i got openwrt,and after upgrade i got LEDE running,and other thing is not necessary do 30/30/30 hard reset,i done via ssh erase nvram reboot and vuola i get deleted dd-wrt and stay with LEDE,just one question in dd-wrt is option that wan port assign as switch port i mean just like simple LAN port in LEDE i did not found this feature and how setup lease time from 24hours just to 2?:astonished:

OK, so I just inherited another one of these from my parents and trying to follow my instructions and the wiki, but now getting an error which I think relates to the fact that the url is "https" as opposed to "http"
with https I get "wget: not an http or ftp url:"
with http I get "wget: bad address ''"
Any suggestions to move this file?

Just a guess here, but if you can't install the appropriate ssl libraries, you could just download the appropriate image from the website using your computer directly, then scp the image file to the /tmp location on the router.

"Bad address" (on a site that does exist) means that the router is not properly connected to the Internet. Simplest workaround is to download to your PC first then scp to the router.

Barrier Breaker has been moved to the "archive" server under a different URL than originally posted. You should use the latest version, 19.07.0.

Oh, I feel so dumb.
Laptop connected wireless to internet
Laptop connected to router LAN side, but router NOT connected on WAN side
Anyhow forgot all about WinSCP when I wrote this. Up and running on 19.07.0.
Thanks for your responses.