How to unlock all 5GHz channels (Super channels)?

I have Ubiquiti Nano-Bridge-m5 nb5g25 model, in my country they use mesh networks to access internet.
wireless regulations are not applied, so they use channels like 164/5820 Mhz and 133/5665Mhz
which is available in Ubiquiti Airos, but unfortunately it's not enabled in lede/openwrt and there's no easy way to enable them.
this is a screen shoot from my nanobridge station :slight_smile:

[NanoBridge M5-Hisham] - Main_20180203203759

also i have tp-link w8970 which is based on atheros AR9381 wifi card, in syslog i see that 5ghz band is disabled :

Sat Feb  3 16:29:41 2018 kern.warn kernel: [   19.473390] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
Sat Feb  3 16:29:41 2018 kern.warn kernel: [   19.477807] PCI: Enabling device 0000:01:00.0 (0000 -> 0002)
Sat Feb  3 16:29:41 2018 kern.warn kernel: [   19.489789] ath: phy1: disabling 5GHz band
Sat Feb  3 16:29:41 2018 kern.debug kernel: [   19.493670] ath: EEPROM regdomain: 0x0
Sat Feb  3 16:29:41 2018 kern.debug kernel: [   19.493685] ath: EEPROM indicates default country code should be used
Sat Feb  3 16:29:41 2018 kern.debug kernel: [   19.493692] ath: doing EEPROM country->regdmn map search
Sat Feb  3 16:29:41 2018 kern.debug kernel: [   19.493709] ath: country maps to regdmn code: 0x3a
Sat Feb  3 16:29:41 2018 kern.debug kernel: [   19.493720] ath: Country alpha2 being used: US
Sat Feb  3 16:29:41 2018 kern.debug kernel: [   19.493728] ath: Regpair used: 0x3a
Sat Feb  3 16:29:41 2018 kern.debug kernel: [   19.507422] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
Sat Feb  3 16:29:41 2018 kernel: [   19.514239] ieee80211 phy1: Atheros AR9300 Rev:3 mem=0xbc000000, irq=144

So is there any way to enable them, Do i need to patch ath.c or regd.c.
When i look at /etc/lib/firmware i see eeprom ath9k-eeprom-pci-0000:01:00.0.bin maybe i can enable 5ghz and change the country code?

Enabling 5 GHz in the TL-w8970's wifi chip will not work because though it may be a dual band chip, it's built as a single band router. The RF hardware between the chip and antennas can only work at 2.4.


Ok, thanks for tell me about that, so what about my nano bridge?

That's called reghacking and it's certainly been done though you should look other places than this forum.


so where to look?
also will this patches will work

Did you know which wifi chip dose nano bridge m5 is using?

The check is inside drivers/net/wireless/ath/ath9k/hw.c.


You can try to comment this if before compiling.

Small guide:

  1. compile once
  2. go in build_dir/target-mips_24kc_musl/linux-ar71xx_tiny/backports-2017-11-01/drivers/net/wireless/ath/ath9k/ and edit hw.c
  3. compile again
  4. flash the firmware on your board and perform some test
1 Like

Thank you very much.
@mk24 tell me that my t-link will not work with 5ghz because the rf chip.
for now i just need channel 164 and 133 on 5ghz band for my nano bridge.

So what? Try it!
Edit this "if" and flash the firmware
Until you don't start to test you can't know if it works or not :slight_smile:

1 Like

ok, i will try then let you know.
but what about super channels on nano bridge?

I don't know anything about super channels
Any news about driver modding?

If you are on the adjacent channel with 40 or 80 MHz enabled, it will use that channel during high traffic.

i didn't get success,it's need someone that have a knowledge with drivers and modding.
super channels= nonstandard wifi channels, some of them are used by ham radio, etc...
at least now i'm using a fiber connection using epon tech.

You won't have success, you originally asked about channels 164 and 133, not non-standard ones.

As @mk24 noted, this is illegal without an Amateur Radio License, and therefore, prohibited discussion on this forum.

If you do possess a license, see here:

1 Like

I nowhere saw @hisham2630 tell which country he lives. It might be legal for him.


yeah it's 100% legal here in iraq.


did you solved this problem ?

No, i just stick to the ubnt firmware!

me too i spend 15 days and try every thing on internet and i get nothing

1 Like

did you solved this problem ? Mr hisham