How to Stop Configuration Rollback - Luci Not Installed

I have flashed current snapshot to an ER-X, initially keeping settings, but also last tried not keeping settings. I manually edited the network file with vi to modify the lan configuration for my network:

a) change static IP to my network subnet 10.xx.xx.xx
b) option gateway '10.xx.xx.yy'
c) list dns ''

When I reboot or power off-on, the changes I have written to the /etc/config/network config file with vi are gone, and the network file has been replaced with the default configuration again. Luci has not been installed yet, so it can't be the Luci auto-rollback after a time delay with no reconnect, can it?

I've done this many, many times in the past on different devices - including this ER-X. I've never had this happen to me before. And its only this one ER-X device. I repeated the process on a different device (same snapshot version), and everything worked as expected, just like in the past: I can reach the device on my lan plugged into the port of one my routers configured as AP/switch, I have internet connectivity through my gateway router, I do an opkg update, I install luci and other packages I use. Simple. If I reboot, everything is as I left it.

Not now. Not with this one ER-X device. I'm beyond exasperated - it keeps rolling itself back to defaults. Which means I have got to be doing something really stupid. That, or there is an evil gremlin inside the router.

Has this happened to anyone before, and if so, can you offer any hints on the stupid thing I'm doing? I promise not to tell anyone you did it too :slight_smile:

Configuration rollback is an exclusive feature of luci, it doesn't exist when you edit the configuration files directly and all changes are final (the same applies if you use uci commands from the shell).

What you're experiencing is probably the overlay not being mounted, which can happen for a number of reasons:

  • you are running (or flashed-) an initramfs image, instead of a sysupgrade image (as you should have done)
  • the firmware is too big to initialize (format) an overlay
  • you overfilled the existing overlay, rendering it read-only

As a first step, before looking any deeper, I'd use sysupgrade -n /tmp/openwrt…insert-correct-image-here…sysupgrade.bin (again). If it starts working then, fine - if not, check "logread" for error messages regarding the overlay.


Thank you slh. Manually scp'ing the sysupgrade image over to /tmp and flashing from the command line with the -n option fixed it.

I was able to rule out accidentally flashing an initramfs image - still had the images in my Downloads folder and they were all sysupgrade.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.