How to speed up and optimize the Archer C6 v2

I've been working on improving the performance of my Archer C6 v2 running OpenWRT 23.05.5.

How to speed up and get full ISP 600mb/s?
Unfortunately LAN connection can't be used. Only 5Ghz

Here are the steps I've taken so far:

  1. Enabled Software + Hardware Offloading
  • Boosts NAT performance by leveraging the router's hardware capabilities.
  1. Enabled Packet Steering
  • Helps distribute packet processing across CPU cores for better performance under load.
  1. Updated firewall4
  • Followed the guide here to resolve potential bottlenecks in the firewall configuration.
  1. Replaced board-2.bin File
  • Followed the instructions from this thread to enhance 5GHz Wi-Fi performance.
  1. Switched Wi-Fi Driver
  • Replaced kmod-ath10k-ct and ath10k-firmware-qca9888-ct with kmod-ath10k and ath10k-firmware-qca9888 for improved Wi-Fi stability and speed.

Connection:
Screenshot_1

Bufferbloat: https://www.waveform.com/tools/bufferbloat?test-id=8da98a78-9d05-4201-96d9-c4f53963577a

My settings:


root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.167",
        "hostname": "OpenWrt",
        "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
        "model": "TP-Link Archer C6 v2 (EU/RU/JP)",
        "board_name": "tplink,archer-c6-v2",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.5",
                "revision": "r24106-10cc5fcd00",
                "target": "ath79/generic",
                "description": "OpenWrt 23.05.5 r24106-10cc5fcd00"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdcf:5bf1:ddc3::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.2'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '192.168.1.1'
        option gateway '192.168.1.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

config interface 'wwan'
        option proto 'dhcp'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '3'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan lan'
        option ssid 'MYNET'
        option encryption 'psk2'
        option key 'pass'
        option wds '1'

root@OpenWrt:~# cat /etc/config/dhcp
cat: can't open '/etc/config/dhcp': No such file or directory
root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'
        option flow_offloading_hw '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'
        list network 'wwan'


by replacing your device, it's not very likely to happen using a C6 ...
wifi and SoC are too slow.

Some of devices with particular SoC have 2 gigabit ports from CPU to switch, on those you can disable VLAN tagging and squeeze a bit more speed (1.3 gigabit total forwarding capacity) , but for this router no chance.

1b hardware offloading is not supported on this SoC
2 one core, steering is no-op
3 thanks. total bulk transfer because of one eth0 is gigabit up+down, not gigabit up + gigabit down. SoC CPU can do a bit more as above
4 that only pertains radio power, eg fixes 3dBm max radio power and similar glitches
5 change back if radio ever crashes, nobody knows which is better.

If you are into experimenting you can rebuild kernel enabling other gmii in DTS file and check if configuring it UP also reflects on switch port 6.

I got one idea (may not work)

Set vlan2 untagged to eth0 (CPU) port and relocate WAN/WAN6/PPPOE to use eth0.

Probably keep wifi up as backup if switch glitches, but in general ethernet sense should work fine.

EDIT:
Part 1 -> Luci-Network-Switch -> change vlan 2 to untagged for CPU port, save apply, if LAN is lost go to wifi and undo

Part 2 -> Luci - Network - Interfaces -> change device on both WAN-s to eth0 in place of eth0.2

Measure speeds.

Edit: tested by myself c7v5, dl in waveform got to 500-few.

After these setting lan connection will be unusable?

You were asked in other thread to provide some information.
Do you get 400-500Mbps each way with offload (obviously capped by subscription if it is less)?
Please confirm using speed test https://www.waveform.com/tools/bufferbloat result links (this does not expose your IP, but you can run clodflare or fast/netflix tests and post the result summary with latency numbers and up down speeds)
v24 has some of improvements present - a zip faster no-offload, a zip slower soft offload, and a zip faster faux hardware offload (in 23 both offloads are same on platforms without offload hardware)

Note that first thing is to confirm that your provider does at least rudimentary QoS, because this eouter does barely have CPU to forward packets at "factory" speed.