How to set multiple kernel_args on adam2 bootloader

I have a FritzBox 7312 wich i want to get asterisk-chan-lantiq to work, but for that i will have to set these additional bootargs to enable a special CPU core for the phone magic: mem=62M vpe1_load_addr=0x83e00000 vpe1_mem=2M maxvpes=1 maxtcs=1 nosmp. Im not 100% sure yet if this will work, but im already struggleing to get the bootargs passed to the kernel.

I set my IP staticly to and FTP'd into the adam2 bootloader by connecting to right after getting the ethernet up. Then i tried quote SETENV kernel_args [stuff above] wich failed because of too many arguments. Doing just one like quote SETENV kernel_args nosmp works fine and can be read back with quote GETENV kernel_args, so im wondering if anyone knows how to escape the spaces. using "s did not work and resulted in the same error.
If anyone knows another method that would be good as well.

Thanks for your help : )

EDIT: This is all the material i used to get this far:

The bootloader cmdline is usually overridden by your device's device tree anyways, so change it there, in the source (DTS).

I tried that already but it had no effect (no change in /proc/cmdline) probably because all flashing methods i know for the fritzbox only accept the sysupgrade image

That doesn't matter at all, DTS takes precedence.

I changed these and tried out the resulting image but it changed nothing. I will check everything again when i get home to make sure i didn't forget to save or something. Will update you then

Turns out i actually forgot to save. My changes were gone when i checked the file again lol

root@Fritzchen:~# cat /proc/cmdline 
console=ttyLTQ0,115200 mem=62M vpe1_load_addr=0x83e00000 vpe1_mem=2M maxvpes=1 maxtcs=1 nosmp

TL;DR dont jump to conclusions

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.