How to set LAN subnet and DHCP assignment range

Why don't you try it out, rather than promising riches for your "colleagues"?

It seems as though you would benefit from some very basic understanding of how Ethernet and TCP/IP work and perhaps some hands-on experience might complement your skill set as you pursue your goals.


Hi, jeff:

  1. Somehow, you skipped my Pts. 1 & 2 and then cited my Pt. 3 as if it were my Pt. 1, then commented. So, it read funny.

  2. Note that at the end of my Pt. 2., I already stated that I was going to get one of the retail routers to check out my configuration. My Pt. 3 was just to outline my test plan for critiques.


I would expect any off-the-shelf router to be configurable and let you decide on the LAN's IP range and DHCP pool size. However, the configuration screen will probably be slightly different on each device, some manufacturers are specially "creative"; but nothing that someone with a basic understanding of the principles can not figure out.

Hi, eduperez, el at:

  1. Thanks for your information and guidance, I purchased a TP-Link Archer C20 AC750 router to do the exploratory tests. I found interesting and encouraging results from the product out of the box. To facilitate the discussion, please refer to the file at the following URL. Basically, I hung the AC750 on my existing HAN as one additional IoT to begin a PAN:
  1. Since the factory default netblock of the AC750 is 192.168.0., while that of my HAN served by Verizon FIOS is 192.168.1., I was able to test the three common private netblocks quickly. Cases A, B & C showed the expected behaviors from the two NBs (HP & Asus).

  2. I then tried to set AC750's IP address to 240/4 netblock. I was not surprised to get a warning message saying this was "illegal". I got the same message attempting to use 224/4.

  3. However, the AC750 appeared to be quite open to other netblocks. So, I tried Case D with 16/4 and followed by Case E with 32/3. Both seemed to work fine without any issue.

  4. But, I got signs of trouble when I tried Case F with 64/2. So, I tried Case G with a smaller subnet, 64/3. It showed sign of some performance recovery. This probably meant that I had hit the processing limit of the AC750.

  5. I repeated Case E as Case H to be sure that the "normal" performance was restored.

  6. While I will spend sometime to digest this set of data, I thought I should share my findings with colleagues on this forum:

A. Being able to operate with 32/3 netblock, the TP-Link Archer C20 AC750 appears can handle a netblock pool of 512M addresses which is twice the 256M that our analysis was focusing upon. Of course, this does not mean it is capable of a fully loaded active operation of these many IoTs.

B. The PAN that this AC750 device established was not accessible from devices on the LAN / HAN part of the setup when I conducted the Angry IP Scan from the PCs on the latter (not recorded on the test result sheet). This confirms the idea that we arrived at through the EzIP analysis. That is, this PAN can become a RAN as long as its transmission facility is isolated from the LAN / HAN and WAN.

C. Note that I am testing the layers of IP addresses right now utilizing the NAT facility. In the long term, the NAT function will be replaced by the Option Word mechanism for stateless routing to achieve the end-to-end connectivity.

  1. So, the AC750 is capable of handling the size of the netblock proposed by EzIP. The next question is whether OpenWrt version is not treating the 240/4 "illegal". Can any colleague on this forum confirm this while I begin to study how to flash it into the AC750?

The above is encouraging. I would like to hear reactions. Thanks.

Configuration of TP-Link OEM software is completely off topic --

You continue to pepper your posts with the name of your commercial endeavor and discuss it in detail, which I find very distasteful.

No need to "study" how to flash OpenWrt on the device. Here are the directions for a v4 device, which is likely current production.

Here are the links to the OpenWrt source code
as well as the documentation of dnsmasq

1 Like
  • I'm not sure what "experimentation" you conducted - all this is known information.

For example:

I'm still confused as to why you seem to have such difficulty in renumbering a network. Perhaps that's why you are pursuing an exhaustion technology...


This requires a lot of changes in source code. I'm not sure why you feel that you've made progress with all this silly "experimenting" on the OEM firmware.

Your RFC Draft says otherwise; and even you acknowledged that to be false. Anyways, I digress.

I agree with @jeff:

We can also glean thatyou didn't install OpenWrt on the device, as it's already been noted to you that you can configure those IPs in OpenWrt (you just continue to claim that I received a negative result):

Dear Colleagues:

  1. Thank you for your enthusiasm.

  2. My experiment report was intended to establish a reference point of capability and limitation, before getting into trying the OpenWrt code. So that I would have some idea where the cause might be when something unexpected happens. And, if I need to reset the router to factory condition, how far should I expect the performance be restored to.

A. Test bed configuration.
B. The Asus EeePC can't detect HP Mini using Angry IP Scan.
C. The off-the-shelf router appears to be able to handle netblock size of /3, bigger than needed /4.

  1. Reading the installation instruction, I found the use of TFTP. Although online articles seem to say that Windows OS has it somewhere to be activated, I could not locate it in my HP Mini with WinXP OS. Can anyone guide me to find it, or recommend where to download a copy?


Then your experiment failed, as you do not use the same procedures under OpenWrt to reset, configure the device, etc. I again don't see what you tested and why. It really seems like you're stalling and just trolling this thread.

I'm not sure why you thought this was impossible to begin with...a router can configure a valid netblock. Again, I don't understand what you were "experimenting" on.

What do you mean by this, and how is this related to OpenWrt?


Windows XP!?!?!
Let's be clear, Windows XP did not include a TFTP client, you will have to download and install one. But I don't advise connecting a Windows XP machine to the Internet, due to security vulnerabilities.

You can try one of these:

Lastly, you failed to address:

1 Like

Yep, you're really on top of technology there. Did you get the message over four years ago

... support for Windows XP ended April 8, 2014. Microsoft will no longer provide security updates or technical support for the Windows XP operating system. It is very important that customers and partners migrate to a modern operating system ...

1 Like

Hi, lleachii:

  1. Thanks for the TFTP recommendation. I then found under

" What TFTP client should I use to flash my device?
Which ever you want! Some suggestions are given below:


So, I will try to use this one to start with.

  1. At the end of the above statement, it mentioned the address of your bootloader tftp server. But, I can't figure out what the value is in the TP-Link AC750 that I have. There are a couple different values mentioned at various places in the OpenWrt documents. And, it also refers to "device wiki" for details, but I could not find that page. Please advice.


Hi, lleachii and jeff:

If you do not mind, I like to put this topic aside for now, because it is tangent to the topics of essence.


So you purchased a router to test openwrt and are giving up just like that.

Do you need step by step instructions.

First tell us what model and version your router is. The information should be on the label on the back of the router.

Hi, mbo2o:

  1. No, somehow you got the incorrect reading. You might have picked up the tread out of context,. Or, the way I replied to colleagues' comments about I am still using WinXP PCs for experiments misled you.

  2. Actually, I reported that I have done a set of basic tests of a TP-Link Archer C20 AC750 out of the box for reference. (See my writing around marker 23/32.) And, right now I am asking questions to gather information about loading OpenWrt code into this router so that I can see how close it may be, relative to the configuration that I need. Please review and advise.


You do realise that you have made this post under installing and using OpenWrt, and for a few days now you have been discussing tangential topics and when other users attempt to assist you ask them to stop because you want to discuss something else.

I hope your next post includes make , model and version number of your router so that we can get this post back on track.

Hi, mbo2o:

  1. Sorry that you got this impression. Scanning through this thread, I can see why this could get out of sync. This is because each new writing is posted at the end of the thread, even though it might be responding to an earlier writing.

  2. As I stated in my last reply to you referring to the 23/34 marker, the model of the the router has already been reported back then. I did not get to the version number earlier. It is a brand new router TP-Link Archer C20 AC750 Ver. 4.1.

You will need to download this file to your PC as preparation for installing OpenWrt

Let us know when your ready for the next step, and advise which version of windows you are using

Hi, mbo2o:

  1. Thank you for jumping in to offer step-by-step instructions. This would be my practice of getting a newcomer started.

  2. The needed file has been downloaded and then put on the PC to be used on the test bed.

  3. This test PC is a HP Mini with WinXP OS.

I'm not too concerned with your test bed just yet, you don't need to jump ahead.

You need to be using a PC that is either windows 7 or Windows 10 to install the firmware on the router with step by step help. The reason been there is a need to test the steps beforehand and it is not possible to test on Windows XP which is obsolete.


Step 2:
Download this file (to the same directory as the first file)

Step 3:
Then from windows powershell
(from download directory or wherever you stored the two downloaded files run these commands)

findstr.exe tplink_c20-v4-squashfs-tftp-recovery.bin .\sha256sums

Get-FileHash openwrt-18.06.1-ramips-mt76x8-tplink_c20-v4-squashfs-tftp-recovery.bin

The first command will display the sha256sum
The second command will calculate the sha256sum

You need to compare the two values (not case sensitive) and if they match you are ready for the next step

1 Like

Most threads work like this one. I believe you're one of the only posters here that always seem confused by the format of this thread.


  • @OugCPC, please inform us when you have flashed the device with OpenWrt.
  • We can proceed from there.

Hi, mbo2o:

  1. Step 2: Clicking on the URL from you, my browser, instead of downloading a file, displayed a full page of HEX codes with comment on the right for each line. The content is clear that it is related to "... 18.06.1 ... sysupgrade ...". I can save it as a "page" that appears to be a text file. Then, it can be opened again by MS-Word with each line wrapped to three lines. Is this normal?

  2. Step 3: How do I invoke the "windows powershell" environment?

  3. I do have two Windows 10 PCs as shown in the test bed configuration. One is an older Dell DeskTop that I will use for the procedures required to make the AC750 to run with OpenWrt code.

Await for your clarification of the above instructions.