How to revert OopenWrt installation back to stock Firmware on Asus GT-AC5300?

After installing OpenWrt I realised that wifi is not supported on the device.

I tried the following with no success:

  1. Uploading the stock firmware over ethernet and using the GUI using: LuCI web interface System → Backup / Flash Firmware → “Flash new firmware image”.
    The uploaded firmware shows the hash value however the router reboots with the same install of OpenWrt and no changes appear to be made.

  2. Using ASUS Firmware Restoration version 2.1.0.3 over ethernet
    This fails saying that the IP range is invalid. I'm assuming the software tries to connect but it can't since the firmware is different. I expected it to fail but tried anyways in case there is some sort of base management controller in the router.

The latest firmware downloaded from the official asus website contains the following zipped file: GT-AC5300_3.0.0.4_386_42643-g16dc577_cferom_ubi.w which is not a .trx or .bin extension but it does seem to pass validation in the GUI.

I've tried different historical versions of the firmware as well with no luck.

There is no recovery method specified on the device page: https://openwrt.org/toh/hwdata/asus/asus_gt-ac5300. How to revert the firmware back to stock?