How to revert back to stock firmware? TP-Link Archer C6 v3.20

I have tried openWrt firmware on my router and I just can not get iPv6 working, rather than troubleshoot it I just want to go back to the original stock firmware, but apparently you need a stripped firmware which I don't have nor do I know how to make one, no such guides on the device page either. I would've tried web recovery but I do not know how to manually trigger it either from openwrt or physically.

There's s web page that can do it for you, it's been posted here, but I didn't save the link ...
Search, and you'll find it.

Only website that I know that does it for you has long been taken down, can you attempt to find the website? (I didn't find a web page about it)

The stripping remove version number too no?

https://argsnd.github.io/tp-link-stock-firmware-converter/index.html

1 Like

Is confirmed working? I really dont wanna bother with a bricked router....

it's been posted here a couple times, if it works for your specific device, noone can tell, but you.

there's also https://openwrt.org/toh/tp-link/archer_c6_v3#debricking

I will try web recovery.

Power cycling did nothing


I don't see the download...


hm...

I flashed it, it is on full light and cannot go to LuCI or ssh, but has internet just fine.

The router's LAN IP is different than openwrt's for sure.

No, i set openwrt to 192.168.0.1, Going to 192.168.0.1 shows LuCI name, then says no webpage

Try incognito mode in the browser.

What ever settings you had in Openwrt, forget about them, they're gone, assuming the flash was successful.

Same thing

Why forget about them? I still have internet on same wifi..

Then you'll need to figure out why, or try resetting.

Restarting router shows pattern like if on stock firmware. Maybe rootfs-data is not wiped?

Yeah, looks like it maybe on stock firmware, I saw ethernet light doing ethernet light on stock firmware, i'll reset later since network is being used