How to retain user specific HTTPS certificate during sysupgrade?


I configured a user specific HTTPS certificate using luci-app-uhttpd. When I do a sysupgrade, the HTTPS access remains enabled after the upgrade but a default certificate (generated by OpenWrt) seems to be used. The user specific certificate is still present and configured within /etc/config/uhttpd but actually not used. Restarting uhttpd or the box does not resolve the situation.

The workaround which I'm currently using after sysupgrade:

  • Disable redirection of http to https
  • Re-Login via http
  • Use the button "Remove configuration for certificate and key" (provided by luci-app-uhttpd)
  • Re-Login via http
  • Select the user specific certificate & key
  • Re-enable HTTPS listener and redirection

This works but is a little bit inconvenient. :wink:

I would be glad if someone could point me to a solution where the existing uhttpd configuration can be re-applied/re-activated after a sysupgrade.