How to remove options for selecting way of booting a VoCore2?

Hello,
I'm using vocore2, when I try to boot vocore2, initially there are some options are shown, on how to boot .

"
Please choose the operation:
0: Load system code then write to Flash via Serial.
1: Load system code to SDRAM via TFTP.
2: Load system code then write to Flash via TFTP.
3: Boot system code via Flash (default).
4: Entr boot command line interface.
5: Load system code then write to Flash via USB Storage.
7: Load Boot Loader code then write to Flash via Serial.
9: Load Boot Loader code then write to Flash via TFTP.
"
actually, this waits 5 seconds to select the boot process, if nothing is entered, it follows the default way to boot.
So how do I need to boot the system with 3rd option without asking for any options to enter?

it isn't openwrt, it's u-boot.

try option 4, and do a printenv.

check the bootm param value.

1 Like

Use option 4 then at the command prompt run setenv bootdelay=1 and saveenv.

This reduces the delay time to 1 second from 5. Setting it to 0 is also possible, but that prevents ever using the other options to de-brick the router.

Thanks for your response, I tried to follow what you suggested, but when I try to print that environment variable it says no environment variables found, and after rebooting, again I'm getting 5 seconds delay to select the boot option.

then the values are hardcoded into the uboot, or you accidentally wiped the uboot data partition.

What is the way to edit uboot?

If they're hard-coded, you need to modify the binary itself, or replace it, if possible.

Do what @mk24 told you, then a printenv again, to see it the value's actually saved.

yeah I tried but, no change at all, getting this

MT7628 # setenv bootdelay=1 
MT7628 # saveenv
Saving Environment to SPI Flash...
Erasing SPI Flash...
.
Writing to SPI Flash...
.
done
MT7628 # printenv
bootcmd=tftp
baudrate=115200
ethaddr="00:AA:BB:CC:DD:10"
ipaddr=10.10.10.123
serverip=10.10.10.3
stdin=serial
stdout=serial
stderr=serial

Environment size: 138/4092 bytes

as you see there is no bootdelay in the list.

Which commands do you have available?

Run help.

And try saveenv bootdelay 1, omitting the =.

MT7628 # help
?       - alias for 'help'
bootm   - boot application image from memory
cp      - memory copy
crc32   - checksum calculation
erase   - erase SPI FLASH memory
fatinfo - print information about filesystem
fatload - load binary file from a dos filesystem
fatls   - list files in a directory (default /)
go      - start application at address 'addr'
help    - print online help
loadb   - load binary file over serial line (kermit mode)
md      - memory display
mdio   - Ralink PHY register R/W command !!
mm      - memory modify (auto-incrementing)
nm      - memory modify (constant address)
printenv- print environment variables
reset   - Perform RESET of the CPU
rf      - read/write rf register
saveenv - save environment variables to persistent storage
setenv  - set environment variables
spi     - spi command
tftpboot- boot image via network using TFTP protocol
usb     - USB sub-system
usbboot - boot from USB device
version - print monitor version
MT7628 # saveenv bootdelay 1
Usage:
saveenv - save environment variables to persistent storage

MT7628 # printenv
bootcmd=tftp
baudrate=115200
ethaddr="00:AA:BB:CC:DD:10"
ipaddr=10.10.10.123
serverip=10.10.10.3
stdin=serial
stdout=serial
stderr=serial

Environment size: 138/4092 bytes

@frollic it didn't worked

In that case start openwrt, and install uboot-envtools.

Try setting the variables from openwrt.

We still don't know if saveenv's doing nothing, or if it's ignoring the settings, or if the partition's gone.

I assume there's no version info anywhere in uboot?
http://vonger.cn/?p=14795