How to mount NTFS [solved]

I'm trying to mount an NTFS partition on boot up but can't come up with the correct fstab line...

I've tried

/dev/sda1 /mnt ntfs (or ntfs-3g) rw 0 0

but that doesn't work.

Mounting the partition using ntfs-3g works OK.

Any suggestions would be appreciated.

Hi balanga,

Did you see this post? Specifically @mike 's comment about using kmod-fs-antfs instead?

Side note: I read an old post on Github that kmod-fs-antfs didn't support some options, such as compressed files and symbolic links, but not sure if that has changed with newer versions.

1 Like

I read it but didn't understand it....

Is this mounting of NTFS done via /etc/fstab or somewhere else?

Not sure where this config global section is supposed to go.

I thought fstab had a strict format.

According to the wiki there is no way to add it in the fstab.

So your best bet is to follow the instructions on the other topic above.

Unfortunately I can't figure what this means:-

config global
	option anon_swap '0'
	option anon_mount '0'
	option auto_swap '1'
	option auto_mount '1'
	option delay_root '5'
	option check_fs '0'

config mount
	option target '/mnt/MV'
	option uuid 'C2FC4BDDFC4BC9FD'
	option enabled '1'
	option fstype 'ntfs-3g'
	option options 'rw,sync'

I have no idea where this is supposed to go.

In /etc/config/fstab. I suppose you have block-mount package installed already.

2 Likes

I don't have such a directory.... I guess it must be created by the block-mount package.

I'll see what happens when I install it.

1 Like

BTW, it's a file.

2 Likes

Thanks to all who helped.

I have it working now.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.