How to make OpenWrt accept Fragmentation Threshold lower than 256?

on OpenWrt 21.02.1 you can't set below that
is there a way to mod fw or force changing it?
those advising older fw v, i thank 'em but i can't

Edit the setting in /etc/config/wireless


And on the web GUI:


1 Like

should i turn it off on the ui and edit file with a txt editor setting in /etc/config/wireless ex:64 ? pelase confirm. tx

Either, or. The same value comes from the config file.

(i.e. it's the same setting)


it shows 64 marked red, assume now its working in 64 ?
anyway to edit the fw so its supports it on the ui as well

fragmentation options ...512, 256, 128, 64, 32 and so on ... wrong ?


This isn't a firewall setting, it's a wireless config. And you should already see it on the user interface - in the wireless section, as previously noted above:


Red == invalid option

Maybe you should first explain...why are you setting the Fragmentation Threshold?

there's 3 streets with heavy traffic between openwrt (client mode with Parabolic antenna) and an external AP.
i noticed by decreasing this i get way less disconnections.




The values are 256-2346 (2346 == disabled). Also note, it must be an even number.

i read it, if am lucky openwrt might use non standard fragmentation as it does in another option on the same menu:

Force 40MHz mode

Always use 40MHz channels even if the secondary channel overlaps. Using this option does not comply with IEEE 802.11n-2009!

you know how to edit the fw to make it get those values through the ui ? tx

Have you browsed to the Wireless section on the web UI?


The 40 MHz setting has nothing to do with fragmentation. And that is a standard option (depending on your card's model).

I'm starting to think you didn't read my post. Perhaps someone else can assist you.

Lastly, I think you're unclear as to what the Fragmentation Threshold setting is; otherwise, I don't understand why you believe that your WiFi will work with a 64 byte frame setting.

nope, i did i say 40mhz is related to frarmentation!
doin my best to make it easy :
i meant, if "B" does't comply .... (not standard)... but its there and it works...
so "A" might be working too if set lower than 256 (even if outa standard as B).

i tasted different values of frag, lower has less disconnections in my config.
the long posts (that i read) simply say: frag lower than 256 don't work, but i thought giving it a try wont kill nobody....otherwise you would be a partner in crime since you told me how :wink:
plus, frag <256 was supported in all older versions


It does comply and is standard (it's 2021 - you do notice, it says 2009 - basically means your WiFi contains a chip made before that standard and can beacon 40 MHz by force, 40 MHz is standard).

No, you cannot use invalid values.



(I'll have to test that - it may have saved the invalid value and did nothing - meaning you're experiencing a Placebo 64 byte frames wouldn't even carry basic network traffic to establish the connection in some cases.)

i was on v18 and it was supported there .... another thing...any idea how to set openwrt to be accessibile (without vpn) from and external ip. tx

(Usually, should search or ask in a new thread for each question.)

ports in 3 and 6 are 80 ?
are the other inputs right ?

Setting fragmentation levels that low can actually increase performance issues...

I snagged this explanation from another open source site...

RTS Fragmentation -

Sets the maximum packet size before the RTS/CTS protection is enabled, if you still have high packet collisions with RTS/CTS enabled and RTS Threshold is at 2346, try lowering it by 10-50 at a time. Lowering it too much can further create overhead and reduce performance as RTS/CTS frames themselves also take up air time & aren't immune to collisions, a good limit is 980, going any lower than 600 - 800 & you'll probably spend more air time transmitting & exchanging these frames than the actual data frame themselves, nullifying any benefit it could of provided as a large amount of the client's communication frames to the AP are <500 ~ 600 bytes at a time. Setting this to 2346 theoretically disables the RTS feature and only leaves CTS enabled as most packets don't exceed 2346 bytes.

Your disconnects may have more to do with the channel selection and width you are using.

You might start by using a wifi analyzer to see what traffic is like in your area, and what channels are being used the most.