How to install web-interface after updating firmware for kimax bs-u35wf

Hello everyone! I need help!

I have NAS device Kimax BS-U35WF. I found this page which contains information about a firmware which must be flashed into my device.

So, I used the web interface to update a firmware thus install the OpenWRT

The process finished correctly. I can see it by flickering indicators. I can connect via SSH to my device.

But, I cannot install a web-interface LuCI because, there is no space for it:

What am I doing wrong?

What happens if you try to install LuCI when you are not in failsafe mode?

How can I switch to non-failsafe mode? I have just updated the firmware. After that I simply connected to my device via SSH and this is what I see.

Execute mount_root and check df again.

If this is running the first flash off of factory firmware, it is often useful to re-flash OpenWrt again from OpenWrt (using sysupgrade -n) to be sure of a good clean install.

I run mount_root and look what I got:


It created a temporary file system /tmp/root. After rebooting the device, it disappears and goes back to its initial configuration.

Can you tell me where I can find the information on how to configure it? I couldn't find in the doc.

"jffs not ready yet" suggests there is a problem formatting the rootfs_data flash. Check dmesg for jffs related errors. I would suggest a re-install then wait at least 5 minutes after it boots for the jffs to be built.

I re-installed the system as you said: using sysupgrade command. After that I run mount_root again it started working in the different way:


Now, it mounts inner memory of the device which 12Mb in the technical documentation.

But, it doesn't save anything after rebooting the system. It goes back to its initial configuration when this memory is not mounted.

What am I doing wrong in this case?

The overlay filesystem not initialized yet should not happen (assuming you waited long enough for the flash to be set up). Read the logs.

I tried to re-install it several times.

Every time when I run mount_root I get the following (in dmesg):

[   49.738285] jffs2_scan_eraseblock(): End of filesystem marker found at 0x10000
[   49.752786] jffs2_build_filesystem(): unlocking the mtd device...
[   49.752792] done.
[   49.768939] jffs2_build_filesystem(): erasing all blocks after the end marker...
[  121.382895] done.
[  121.401722] jffs2: notice: (473) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[  121.474906] overlayfs: upper fs does not support tmpfile.

Please, help me. I don't understand what I am doing wring!

cual es la contraseña por favor? hice lo mismo...


I have no password. Try to use admin.

No, on default OpenWrt the password empty.

No, en OpenWrt predeterminado la contraseña está vacía.

Username: root

Simply press the Enter key.

Simplemente presione la tecla Enter.