How to install snapshot?

Hi! I need to install this snapshot on my Archer A6 v2. However, when I tried to flash it, it bricked my router. Hopefully, I was able to restore it using TFTP. What's the correct way to install such a snapshot?

The link leads to an individual old source commit, not into any firmware image...
I hope that you didn't try to flash the short source change by itself.;a=commit;h=d03aae1a09fce5a5d5747855bc07ee1f54388e03

This specific snapshot version is not there. I need that because it contains a fix for an issue. I don't know it future snapshots have that fix, but the lastest official build still has the problem.

An older thread led me there. The author of this comment says this commit solves the issue, but he doesn't explain how to install the patched firmware...

Well, that patch is from year 2020:
Fri, 13 Nov 2020 13:49:27 +0200 (12:49 +0100)

All versions of OpenWrt since then, meaning

  • 21.02 (status: end-of-life),
  • 22.03 (retired, security maintenance),
  • 23.05 (current stable) and
  • the development main/master snapshots

do already include that patch by default.


But surprisingly installing the latest stable version did not work. The WAN ip could not be auto-detected and I could not get internet. Maybe I did something wrong, but shouldn't the router get a WAN IP with the default configuration?

It might be a new bug.

It does.
Normally. (for me it still does)

1 Like

There's a routing bug, where traffic isn't forwarded to wan, isn't there ?

Fixed by one command post boot.
Just need to find it.

I think so. What is the command? I tried searching but nothing worked.

I'd need to search too.

In the meantime, try 22.03.5.

Thanks, I'll try installing 22.03.5. But there's one more problem: I need to free around 500kB in order to be able to build the image. These are the packages I need: ath10k-firmware-qca9888-ct base-files busybox ca-bundle dnsmasq dropbear firewall4 fstools kmod-ath10k-ct kmod-ath9k kmod-gpio-button-hotplug kmod-nft-offload libc libgcc libustream-mbedtls logd luci mtd netifd nftables -odhcp6c -odhcpd-ipv6only opkg -ppp -ppp-mod-pppoe procd procd-seccomp procd-ujail swconfig uboot-envtools uci uclient-fetch urandom-seed urngd wpad-basic-mbedtls umdns miniupnpd openvpn-openssl openvpn-easy-rsa -luci-theme-bootstrap -luci-ssl -ip6tables -kmod-ipv6 -kmod-ip6tables. Without openvpn-openssl openvpn-easy-rsa it works fine, but I need OpenVPN Server. Which packages are safe to remove?

openvpn-easy-rsa is only needed for creating the certificates, you can do this on your host computer. Do you really need miniupnpd and umdns?
You are also mixing two SSL libraries, if you stay with either it will reduce size (try openvpn-mbedtls instead.

1 Like

Just FYI, your device will be EOL:ed after 23.05, due to insufficient flash space.


I need UpnP and mDNS for Home Assistant discovery. I'll try installing openvpn-mbedtls and see if that works. It's a bummer though that I have to remove so many packages, I don't know how they managed to fit OpenVPN, UpnP, mDns, ipv6 and others in the stock firmware without any problems.

Could you elaborate that a bit? I'm running Home Assistant, too, and my router has neither of these packages installed - auto discovery is working just fine.

I though you need mDns discovery enabled in the router to be able to auto-configure devices in your network. And UpnP is for showing router data in Home Assistant (like GB sent / receive)

No, the point of mDNS is that it doesn't require a central server (in contrast to DNS). You need mDNS on OpenWrt only if you want your router to be auto-discoverable.

And regarding UPnP, I suggest to read the following Wiki page:

Are you sure you're not confusing SNMP and UPnP? However, there are unofficial OpenWrt integrations into Home Assistant that could also work.

1 Like

Thanks. I'll see if that works

I just checked myself and installed mini_snmpd on my OpenWrt boxes: I can see the counters using snmpwalk, so it's just a matter of correctly setting up Home Assistant to display the stats.
Be aware that mini_smpd only supports 4 interfaces (according to the configuration file, I didn't check it myself).