How to install OpenWrt on AVM Fritzbox 7412?


I'd like to install OpenWrt on an AVM Fritzbox 7412, so that router could be used as a Freifunk AP.

But, sadly, I can't manage to install OpenWrt ....
I tried to install it using AVMs update option within their GUI, but that doesn't work - after some minutes a error-message occurs saying "something went wrong, please retry or reboot ...".
So I tried using the ftp way, but that doesn't work either - but I always get a "no route to host" message. For sure both system (7412 and PC) are within the same net :wink:

Any ideas or hints?


@xambrian, welcome to the community!

Did you try the installation instructions at the link found on the device's Techdata page?

Thanks a lot, @lleachii :slight_smile:

Yes, after contacting Andy Binder I took the proper script.
When running the script I get:
root@debian:~/eva# ./ IP-ADDRESS openwrt-lantiq-xrx200-avm_fritz7412-initramfs-kernel.bin

SETENV memsize 0x07bb8000
< 200 SETENV command successful
SETENV kernel_args_tmp mtdram1=0x87bb8000,0x88000000
< 200 SETENV command successful
< 200 Media set to MEDIA_SDRAM

After another ~5s Power/DSL led blinks red pretty fast ... and that's it.
There're no changes even after 20m, so I have to un-power the device, and after powering it up again there's still the original AVM-firmware running.

Maybe its way too complicate for me ...

This manual worked for me. Unfortunately it's in German only.

You may start directly with the ftp part.

EDIT: I've flashed 19.07.0-rc2

EDIT2: Is there a chance to get a working mesh between the FritzBox and Linksys WRT1900ACS?

You may want to create a new thread for your mesh inquiry.

1 Like

Yes I agree:

1 Like

Hi there,

I'm struggling with the instruction at
After installing and running openwrt 19.07.2 I still got the problem of falling back to Fritz!OS after rebooting the 7412.

Is this normal?
I even tried the "Boot Partition auf 0 setzen" and a re-install afterwards.

Thank you for your help.


You haven't forgotten to run the sysupgrade?

1 Like

Thank you very much for that fast reply!

I'm not sure about the sysupgrade.
Therefore, I will give it a fresh new try today.

EDIT: It finally worked, thanks a lot!
Yes, indeed I made a mistake by not running the sysupgrade.

You are welcome!

hello guys,
i want to install the latest version on the 7412.
i use a mac for installation.
when i do the last step with the update, the system log me automaticly out and reboot.
when the reboot is ready i still have the latest fritz os on the box?
can someone help me to fix it?

no one have an idea?
can anyone help me to change the bootpartition with a mac os?

I think you have tun run this before the in case the FritzBox ist still booting FritzOS:

root@caleb:/openwrt/scripts/flashing$ ftp

Connected to

220 ADAM2 FTP Server ready

-- Username --

Name ( adam2

331 Password required for adam2

-- Passwort --

Password: adam2

230 User adam2 successfully logged in

Remote system type is AVM.

-- Set boot partition to 0 --

ftp> quote SETENV linux_fs_start 0

200 SETENV command successful

ftp> quote REBOOT

221 Thank you for using the FTP service on ADAM2

ftp> quit

221 Goodbye.

Your install procedure itself looks fine.

hello wrter,
thanks for your answer :slight_smile:

but here i think i have a problem, because the mac os tell me unknown command ftp:

you have an idea?


maybe i have a problem to get it work with a mac?

You could try the second answer:

hello wrter,
i found this too, but i think i get other problems because missing commands. see the describtion to change the bootpartition.
i installed now ubuntu in virtualbox. but now i get no connectin to the 7412.

hello wrter,
i get it worked with ubuntu :+1:
thanks for your help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.